2

I've just received my Chromecast, just started to install. But when I need to select my WiFi network, it isn't there.. When I enable my hotspot of my Android phone, it's begin displayed.. (But yeah, I don't want to use my 3G to stream movies haha)

My router is a Cisco EPC3925.

I've done the following things:

  • Enabled uPnP
  • Searched for the AP isolation option, found nowhere.
  • Tried different security modes and encryption's (Normally WPA2-Personal, TKIP + AES).
  • 2,4GHz networking

(If you need to know any other item/configuration thing, please let me know!)

Currently I don't have any other router that I can try with (only the hotspot). Also, different other WiFi networks are displayed, so I don't think that it has something with my Chromecast.

Thanks,

  • Is your network 2.4GHz or 5GHz? – nerdwaller Dec 3 '13 at 20:15
  • 2,4GHz, 5GHz is not supported, yeah. Also found that :S – Wouter0100 Dec 3 '13 at 20:15
  • Haha, good good. If you don't get answers, you probably also saw the contact numbers. – nerdwaller Dec 3 '13 at 20:16
  • Yeah, I did haha. But yeah, English is not my best language :p Thanks anyways! – Wouter0100 Dec 3 '13 at 20:18
2

Found the problemen, our router was running on channel 13. Changed to Auto (1) and it worked.

  • I thought 2.4GHz in the USA was restricted to channels 1 through 11. – jarmod Dec 31 '13 at 3:03
  • Didn't help me :S I got Netgear R6100. Can't make it work with Chromecast at all. It just doesn't see my net. – Schultz9999 Jun 24 '14 at 4:02
  • Wich channel is your network running on? – Wouter0100 Jun 24 '14 at 7:50
0

https://www.whistleout.com/CellPhones/Guides/Chromecast-not-working-with-WiFi-help

Adjust your router channels

Lastly, most routers come set up to select what wireless channel they run on automatically. This can mean that your network ends up operating on the same channel as your neighbours, which can cause interference.

Go in to your router settings. Instructions of how to do this should be on the underside of your router. If not, try a web search using your router’s brand and model number.

Look for a section called “Wireless” and a subsection called “Channel and SSID”. The names of these menus may vary depending on your router.

Find the “channel” field. If it is set to “Auto”, change it to any numbered option. If the problem continues, change it again until you find a channel with less interference. Alternatively, use a tool like WiFiInfoView to take a look at your surrounding WiFi networks and what channels they run on.

Popular opinion around the web is that Chromecast operates best on channels 1, 6 and 11, although we’ve seen no evidence of a specific channel making a spot of difference. Just make sure that as few of your neighbors as possible use the same channel as you.

This will not only improve Chromecast performance, but WiFi speeds and reliability in general should be better once you make the change.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.