24

I have a Windows 7 x86 virtual machine that hadn't been used for a while, and today I did a full Windows Update on it (including getting IE11).

I noticed that I hadn't turned on Microsoft Updates, and when I open Windows Update and clicked on the "Get Updates for other Microsoft products. Find out More" link, Internet Explored starts up and takes me first to:

http://www.update.microsoft.com/microsoftupdate/v6/ …. (and something I didn't catch)

Which immediately redirects to

http://www.update.microsoft.com/windowsupdate/v6/thanks.aspx?ln=en&&thankspage=5

Which seems to only contain this image:

enter image description here

This page is not what I was expecting (Microsoft update license etc) and simply shows me how to click on the start menu and run Windows Update.

Does anyone have any idea what is going on here? And how do I actually get Microsoft Updates turned on? This has never been an issue for me in the past.

Note that Windows Update is running perfectly happily on this machine.

  • Run SC WUAUCLT MODE=AUTO from the cmd as administrator. – arielnmz May 14 '14 at 22:51
35
+50

OK .. I now have justification for bashing my head on the table.

I discovered another website that was not working with my VM - but I had a second VM for which it did work. In the VM that worked I had IE9, but in the VM that doesn't work I have IE11. That lead me to remembering that there had been "recent" changes in IE, and then adding that website to the IE11 "Compatibility" mode. After which it worked.

So … I added microsoft.com to the IE11 compatibility mode and all of a sudden I see what I expected:

enter image description here

Which finally led to the following (which looks very similar to the initial page I was seeing)

enter image description here

So the problem is that IE11 can't handle a Microsoft website. Oh the irony.

| improve this answer | |
  • 2
    Is it not a bit ridiculous that even in 2015, Microsoft's web browser needs to use compatibility mode to display Microsoft's website properly, on a page needed to update Microsoft products? – George T Apr 21 '15 at 19:36
  • It's worth noting... or is to me, at least, that this same issue impacts the server versions of Windows as well, or at the very least Server 2008 R2 (don't have any 2012/2012 R2 servers I can test this on at the moment). Anyway, thanks for helping me figure out why I couldn't use Microsoft update on a bunch of my servers. – HopelessN00b May 20 '15 at 19:11
  • Is this workaround broken in March 2017? Just tried it, including disabling both checkboxes ("display intranet...", "use microsoft"), but it failed. – Tobias Knauss Mar 7 '17 at 11:54
  • Finally I decided to install Silverlight as suggested on another website. The installer gave me the option to enable Microsoft Update as soon as the installation was done. Succeeded. – Tobias Knauss Mar 7 '17 at 12:08
8

It's definitely an issue with IE11 as suggested by other posters. I needed to check the "Use Microsoft compatibility lists" option in the "Compatibility View Settings" in IE11 in order to be able access the correct page.

enter image description here

I tried adding the microsoft.com website to the IE11 compatibility list and it didn't work for me. Hopefully this works out for you.

| improve this answer | |
  • +1 This solved my problem, and now you will be able to include images in your answers :) – Oriol Sep 5 '14 at 14:38
  • This should take over as the accepted answer. The currently accepted answer will force all Microsoft sites into compatibility mode unless they explicitly ask for standards mode e.g. via the X-UA-Compatible header. – Starson Hochschild Nov 20 '14 at 20:21
  • There's something odd going on here. "Use Microsoft compatibility lists" is on by default, but the MU page still doesn't work - until the second or third time you try it, when it suddenly starts working for no readily apparent reason. – Harry Johnston May 18 '15 at 0:12
2

You can enable Microsoft update with a vbs-script too if IE don't allow you at all;

Set ServiceManager = CreateObject("Microsoft.Update.ServiceManager") 
ServiceManager.ClientApplicationID = "My App"  
'add the Microsoft Update Service by GUID 
Set NewUpdateService = ServiceManager.AddService2("7971f918-a847-4430-9279-4a52d1efe18d",7,"")

or that one to undo the change;

Set ServiceManager = CreateObject("Microsoft.Update.ServiceManager") 
ServiceManager.ClientApplicationID = "My App"  
'remove the Microsoft Update Service by GUID 
ServiceManager.RemoveService("7971f918-a847-4430-9279-4a52d1efe18d")

reference there

| improve this answer | |
  • Someone added a powershell script solution in a comment on the link you referenced: (separating the 3 lines by ///): $ServiceManager = New-Object -ComObject "Microsoft.Update.ServiceManager" /// $ServiceManager.ClientApplicationID = "My App" /// $ServiceManager.AddService2( "7971f918-a847-4430-9279-4a52d1efe18d",7,"") – Tobias Knauss Feb 15 '18 at 17:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.