4

It seems my microphone and speaker devices are swapped somehow.

device

(Note that this device can detect whether my mic is unplugged/ plugged in)

I cannnot input sound using my microphone

However, when I try to record sound

record

It records system sounds instead of my microphone.

Also, when trying to configure speech recognition

recog

It picks up system sounds rather than my microphone.

I think I am missing some conceptual understanding of how devices work on windows.

How do I fix this so I can use my microphone again?

EDIT

realtec

mic

I'm currently using the pink front panel for mic input

  • On your front panel the have the pink and green, try either swapping them in the audio manager or plugging the speakers into pink instead and the mic into green instead. – BigJayMalcolm Dec 4 '13 at 13:46
  • I've tried swapping these in all combinations. Still no luck. I've also tried dual booting my PC with linux and using skype on ubuntu. My mic works on Ubuntu fine, so its not a hardware issue. – sav Aug 18 '14 at 15:02
1

As you're using Realtek you could try opening the Realtek audio manager swapping what port does what by right clicking on the port on the right hand side and chose connector retasking.

It's worked for me before when i needed to swap something - so hopefully fixes your issue.

0

I finally figured it out

I uninstalled realtek, unfortunately it seems I had to do this.

then set my speaker and mic to default device as in pics below

mic

speaker

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.