I just got a new monitor: an Acer B276HUL. Its native resolution is 2560x1440. I didn't do my research before ordering it; that resolution is too high for single-link DVI! So I have yet to see it operate in its native resolution. But I'd like to try it.

I have a Mac Pro laptop, and a Monoprice adaptor for mini-DisplayPort to DVI, HDMI, or DisplayPort. And the monitor came with a DisplayPort cable. So I tried to connect the monitor to the Mac using DisplayPort. The Mac did not recognize the monitor.

When I use the DVI adapter and plug in the cable, the Mac recognizes the monitor: if I have the System Settings open to Displays, then when I plug in the cable, settings for multiple monitors appear. When I unplug the cable, those settings disappear. But when I unplug the DVI cable from the adapter, and plug in the DisplayPort cable, the Mac does not react to the adapter plugging and unplugging.

I have gone into the menu on the monitor and set it to "Input: DisplayPort" before trying the above experiment. No success.

I found a discussion page that suggested restarting the Mac in "Safe" mode, and I tried that. It didn't help; the monitor was not recognized.


Isn't a mini-DisplayPort to DisplayPort adapter just an electrical pass-through? So, shouldn't this trivially work?

Is there a chance that it would work if I got a simple adapter that only does mini-DisplayPort to DisplayPort?

If I were to buy an Apple branded mini-DisplayPort to DisplayPort adapter, is that likely to make any difference?

  • Could you provide a link to the miniDP adapter you have? If it's passive, it will not work with a 1440p monitor because the resolution requires Dual-Link DVI, which you cannot passively convert to DisplayPort. – helrich Dec 5 '13 at 21:48
  • Here is the link to the adapter. It says it does not support dual-link DVI but does support full resolution DisplayPort. monoprice.com/… – steveha Dec 5 '13 at 22:55
  • Ah there you have it then. It supports full DisplayPort when using the DisplayPort to miniDisplayport, but the maximum resolution is capped at 1080p via DVI (single link only), most likely because DVI and DP use different clocks, so it isn't as simple as a straight pass-through. You'll need to find an active adapter. I have a couple in my system, and they require a USB connection for extra power. – helrich Dec 6 '13 at 14:17
  • But the question is that the Mac doesn't recognize the monitor when using the DisplayPort input of the monitor, a DisplayPort cable that came with the monitor, and that adapter to connect the cable to the mini-DisplayPort port on the Mac. The monitor is recognized when I try it with DVI but of course I don't get the full resolution; but with DisplayPort the Mac acts like there is no monitor (does not react to plug/unplug events). – steveha Dec 6 '13 at 20:47

After much fscking around I came up with a solution, I think. At least it's working for me.

On Monitor OSD:

  • Settings
  • DP (scroll way down)
  • DP 1.1

You might have to plug into a source that works in order to use the OSD, I had to plugin an HDMI source before it would let me do anything.

This should get you an image at 2560x1440.

If it's jaggedy and terrible looking try pasting the following xml and rebooting:


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
  <string>Acer B276HUL (fixed)</string>

Original comment:

I did the exact same thing, right down to plugging into the wrong DP input on the monitor. > Acer really should label these as input and output...

Anyway after plugging into the correct jack, I get the exact same thing... monitor is recognized but stays black or 'no signal'.

I was thinking it was maybe a hardware failure until I got it working at full res in windows.

So, it's a configuration issue... somewhere... just don't know where, yet.

| improve this answer | |
  • A correction to the answer about setting DP 1.1 and creating an overrides file: You don't need to restart your Mac. You just need to disconnect and re-connect the DisplayPort cable. It will pickup the overrides file when the display is re-connected. – Jacob Barrett Feb 13 '14 at 18:27

The Mac is now recognizing the monitor. The monitor doesn't work, so I might file another question, but this question has been answered.

The problem was: there were two DisplayPort ports on the monitor, not just one, and I was trying to use the wrong one. One is "in" which is what I should be using, and one is "out" (for daisy-chaining).

With the cable plugged into "out" the Mac didn't recognize the monitor at all. It acted like the cable wasn't even plugged in.

Now, the Mac recognizes the monitor. In Settings, in "Displays", when I plug in the cable the "arrangement" tab appears. However, the monitor reacts with "No signal" and then goes blank.

I tried booting the Mac to "safe mode" and that didn't help.

P.S. This latest round of testing is using an actual mini-DisplayPort to DisplayPort cable, not the adapter from MonoPrice. I should try that adapter out and see if it works the same as the actual cable.

| improve this answer | |


I had exactly the same problem: Acer B276HUL recognized by OSX (Yosemite on 27" iMac Late 2010) but no picture displayed.

  1. Boot with Windows (Luckily, I had Bootcamp Enabled with Windows 7). With Windows 7 B276HUL worked without any issue
  2. Go to Acer Menu Display Settings/DP/ and select DP 1.1 instead of DP 1.2
  3. Reboot with OSX and problem solved! :D

In brief, select Acer B276HUL DisplayPort 1.1 for OSX compatibility. DisplayPort 1.2 doesn't works with my iMac (late 2010)

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.