My first intention to setup a PPTP VPN, via my Linksys E2000 router with DD-WRT firmware, was to use an iPhone app while being connected to my home network from anywhere I have an internet connection. That is working. However I am finding out I cannot check my emails using my iPhone while it is connected to the VPN. But if I am not connected, I can check emails. My VPN client is my iPhone 4 running on iOS 6.1.2.

What could be causing this? Here is my PPTP VPN setup within my router:

pptp server: enable
broadcast support: enable
force mppe encryption: enable
server IP:
client ip:
Chap-secrets: username * password *

Routing Table:
LAN NET        Subnet Mask       Gateway      Interface      ppp1      ppp0      ppp0      LAN & WLAN  ppp0 

My router IP is

Other. Although these are enabled and set, it didn't make a difference if I shut them off or on. It works both ways. VPN passthrough: all 3 enabled ports forward: 1723 & 1792

  • Can you post your routing table? – MariusMatutiae Dec 5 '13 at 9:48
  • Ok. I thought I had it fully working, but I was wrong. In my iPhone settings, if I unchecked the 'send all traffic', I am able to access my emails, but I lost access to my local network. Internet still works although. I believe I need to write a rule to my router letting the client check their emails while having the 'send all traffic' button checked. Anyone knows how? Maruius: The VPN Server is my router, how can I access the routing table? – ducsu Dec 5 '13 at 23:30
  • Sorry, I am not sure how to use this interface. I've listed my routing table and separate the lines a 'comma' for a better visual. LAN NET Subnet Mask Gateway Interface; ppp1; ppp0; ppp0; LAN & WLAN; LAN & WLAN; edited ppp0 – ducsu Dec 6 '13 at 0:06
  • In this form your routing table is inintelligible. Could you pls post it by adding it to the OP? Ty – MariusMatutiae Dec 6 '13 at 7:04
  • @MariusMatutiae Thanks for the replies. I've added the table into the OP. – ducsu Dec 6 '13 at 9:31

The problem is not with your routing table, it looks just fine. What is not correct is however your configuration file, and there might be a problem with the configuration for use with IPhones. I suggest you make a copy of the current file, to be used in case of disaster, but then let us proceed to write a new one.

You can check the proper way to configure your VPN here, but I will walk you through this.

I think the first error is in the WINS2 address. You used an OpenDNS address, while WINS2 should be an address within your LAN; from this I deduce you do not have a WINS2 server on your LAN (most people do not, I certainly don't), so just drop this line. The DD-WRT manual link above states:

WINS Add your local WINS servers. This settings are optional.

(Emphasis mine).

Then the server IP is wrong; the guide states

Server IP. Your LAN IP Address.

You can use your router's LAN address,

Then there is the client IP address range. The guide states:

Client IP(s) The client IP range. Leave it blank will not work. ... Should be a valid IP Address on the LAN segment of the network.

Thus it should be within the range Please pick a range, not just an individual address, because syntax may be sensitive to the lack of a dash.

Lastly, the peculiarity of IPhones. The same guide, a tad later, here, states that there is a DNS problem with IPhones, and that addition of a few lines to the router start-up script will cure this problem. This point is a bit dubious, because it is not clear whether this DNS problem affects all IPhones, or only some versions of IOS (and thus no point in my asking which one you are using). Thus I suggest you try your VPN without this correction first; then if it fails, you set it up as per the link provided.

| improve this answer | |
  • Followed your steps. Still not working. Acts the same way with my initial setup. I changed the dns1 to reflect my isp. Here is a funny quirk. I left wins1 blank, but it automatically input dns1 line after I save. At any rate, if I leave dns1 blank, I can still connect to my vpn but I can't access my email. Next, I changed my server ip to match the same as my router. The client ip I set a range like so. ''. Saved the settings and test. Doesn't work. Act the same. Next, I added the bug script for the iphone. Save the script & reboot. Still no go. – ducsu Dec 6 '13 at 11:55
  • Also, I made a typo in my OP. I meant to write wins1 and not wins2. Wins2 has always been blank, but wins1 is filled in automatically with dns1 line. – ducsu Dec 6 '13 at 12:43
  • OK. I got it working now. With the same settings as @marius suggests and an update of my dd-wrt firmware, I am able to access my email, launch apps that uses Internet, access my local network and browse the Internet while being connected to the router VPN. Thank you very much for the help. – ducsu Dec 6 '13 at 15:40
  • @ducsu If it works, please select my answer so that other people know this is the correct solution. Thank you – MariusMatutiae Dec 6 '13 at 17:05

See http://cnedelcu.blogspot.sg/2011/10/pptp-server-fix-for-ios-problems.html

Here's what got it to work for me. You need to open up the options file for pptpd usually located here: /etc/ppp/options.pptpd At the very bottom of the file, insert the following lines:

mtu 1400
mru 1400

After saving the file, make sure to restart pptpd properly (I stopped it and started it again completely) and try connecting from iOS again. Worked for me! Hope it will for you as well.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.