1

Ok, so bear with me, not sure how to explain this.

So after about 10 hours of constant running my computer/keyboard starts to act weird.

Its as if it has caps lock depressed continually, along with I think a ctrl key.

  1. If I hit caps lock, It works for the letters as it would normally. But if I type . I always get the > symbol. No matter if caps lock is on or not.
  2. It seems to effect mouse functionality to. For instance in gmail, I clicked on a email in my inbox and used the scroll to scroll down the message, but for some reason it closed the email and went back to the inbox.
  3. Num lock and scroll lock are both off.

Any ideas..

It kind of hard to explain the situation because it only happens after a long usage period, and when it does it somewhat renders the computer unusable.

I think it is related to this post Caps Lock is mapped to Shift but it doesn't really make sense to me? How would I all of sudden gain a different keyboard mapping?

EDIT: I forgot that I should've put what solved it directly in the question. What solved it for me was pressing both the left and right shift keys simultaneously.

  • Is this a laptop, or a wireless keyboard? – Mat Carlson Dec 5 '13 at 19:42
  • Desktop, wired keyboard. – KDecker Dec 5 '13 at 19:45
  • I've had that happen when I'm using a keyboard with media/custom keys (like most Wireless keyboards). Maybe try uninstalling any software for your keyboard, if you have any? – Mat Carlson Dec 6 '13 at 15:21
1

One possible reason could be some type of Malware. Use something like malabytes anti-malware to just check quickly. Malwarebytes is a safe program and free.

Else, you might have something messed up in your registry, try downloading Ccleaner. This is another free software that can help you. Ccleaner.

As another option you can go into 'control panel' -> 'region and language' and make sure your keyboard is the right setting.

If it is a wireless keyboard you may need to replace the batteries or make sure nothing is obstructing the connection. If it is wireless just conduct a little troubleshooting.

  • 1
    Malwarebytes found some possible malware reg keys. Ill delete them and see if anything changes. reporting back in ten hours... – KDecker Dec 5 '13 at 20:02
  • 1
    Ok here is the fix, I figured it out..... Hit both the shift keys at the same time and it stops. Still not sure what starts it going.. – KDecker Dec 6 '13 at 20:03
1

My Caps Lock was not turning off as before but, after days of frustration, I solved the problem today:

  1. Control Panel
  2. Select - Region & Language
  3. Select - Keyboards and Language
  4. Select - Advanced Key Settings
  5. Where it says "To Turn Off Caps Lock" there are two buttons - click the one that says 'Press the Caps Lock Key'
  6. Click 'Apply'

If the 'Press the shift key' had been selected, that was your problem!

0

Try a different keyboard for a while, see if it still happens, so, you know whether it is really related to the keyboard itself.

(I have a similar issue on an ASUS N55SF: the 'Alt' regularly gets stuck even though it really is not physically. On the same laptop, they had an issue where the NUMPAD key is physically missing and they had to issue a BIOS fix to simulate the presence of a numeric pad lock -- else none of the numpad keys would work as numbers. Those are 3 different issues but my point is that keyboard issues may be BIOS related, nor just hardware.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.