3

Google Chrome Version 33.0.1726.0 dev-m
CCleaner V.4.08.4428(64bit)
Windows 8.1 64bit

Problem Description: After cleaning Chrome's "Internet History", Google Chrome's preferences become corrupt. I've been able to reproduce this four times and I've narrowed the cleaning options down to "Internet History" as the culprit.

The items cleaned under Internet History were 7 files:

  • Archived History
  • Visited Links
  • Current Tabs
  • Last Tabs
  • Top Sites
  • History Provider cache
  • Network Action Predictor

After referring to an earlier screenshot I took I may be able to eliminate "Last Tabs". I was able to reproduce the problem without that item cleaned.

This always yields the message: "Your preferences can not be read. Some features may be unavailable and changes to preferences won't be saved".

Navigating to: C:\Users\WindowsUserName\AppData\Local\Google\Chrome\User Data\Default shows us Preferences and Preferences.bad. It's almost useless to back up the preferences file as Chrome's extensions sometimes become unusable and must be reinstalled.

What doesn't fix the issue:

  • CCEnhancer 3.8 has been used and eliminated as a contributing culprit after removing its custom cleaning definitions.
  • Reinstalling Chrome has been tried twice and does not solve the issue
  • Reinstalling the latest version of CCleaner does not solve the issue (before or after using CCEnhancer).

Again, I think the important discovery here is whatever Chrome is cleaning under Internet History. Their relation to the preferences file is beyond me. Should I file a bug report with this build of chrome? What else could I try?

2
  • You said that CCleaner is corrupting Chrome’s preferences file in the title, but then in the body of the question, you said that you ruled CCleaner out and that it is Chrome itself that is corrupting it. So which is it?
    – Synetech
    Dec 21 '13 at 4:49
  • I ruled out ccenhancer and narrowed it down to a ccleaner option that cleans out the internet history. I didn't mean to rule out ccleaner itself.
    – VitaminYes
    Dec 27 '13 at 15:17
4

It’s because you have the compact-chrome-databases option checked. Apparently it has a bug that is causing problems. It is a known bug, and they are working to fix it. You can sign up at their forums and submit your preferences file so that they can analyze it to figure out what’s going wrong.

(This isn’t the first time that the function hasn’t worked correctly, but to be fair, Chrome uses FTS3 which makes compacting its databases risky to begin with.)

Until Piriform can fix the bug, you should just un-check the compact-databases option and use only the cache-clearing function:

Screenshot of CCleaner’s Chrome options with compact-databases un-checked

3
  • That's probably it! I'll have to confirm this when I next get the chance.
    – VitaminYes
    Dec 30 '13 at 16:12
  • @VitaminYes - Was this resolved? Still causing issues?
    – Alex S
    Aug 27 '15 at 12:50
  • At the time, this worked. However, I haven't been using Chrome for almost a year now. I don't know if this bug has come back
    – VitaminYes
    Aug 28 '15 at 1:31
0

Yes, with the 'Internet History' option checked in any version of CCleaner seems to corrupt the 'Prefences' file for some bizarre reason.

1
  • Agreeing that there is a problem is not a solution to the question.
    – fixer1234
    Oct 1 '15 at 6:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.