3

My Photoshop CS6 crashes when both VGA-s are enabled. If I disable the Intel HD 3000 in Device Manager it works fine.

The error:
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name: Photoshop.exe
  Application Version:  13.0.0.0
  Application Timestamp:    4f61c045
  Fault Module Name:    aticfx64.dll
  Fault Module Version: 8.17.10.1230
  Fault Module Timestamp:   52540642
  Exception Code:   c0000005
  Exception Offset: 00000000000a1a4e
  OS Version:   6.1.7601.2.1.0.256.1
  Locale ID:    1033

Display Adapters:

 AMD Radeon HD 7770 (Gigabyte)
 Intel HD 3000 (Core i5)

I use both cards, because I have 3 monitors:

1 VGA on Intel
2 DVI on AMD 
3 Mini display port on AMD

All drivers are up to date, I use 64 bit Windows 7, all updates are installed. Photoshop is also 64 bit. System memory: 16 GB.

When I start Photoshop, Graphics Processor Settings are grayed out (Photoshop detected an error in your display driver.) With Intel HD 3000 disabled it works.

0
2

The issue is you're using 2 unrelated graphic cards. You need to use either 1 graphic card, or multiple versions of the same graphic card.

Multiple video adapters can cause problems with GPU-accelerated or enabled features in Photoshop. It's best to connect two (or more) monitors into one video adapter. If you have to use more than one video adapter, make sure that they are the same make and model. Otherwise, crashes and other problems can occur in Photoshop.

Source

4
  • Very nice Adobe :) I'll have to buy another mini display port->vga adapter and disable Intel HD totally. Or use 2 monitors whenever I use Photoshop. – Mart Dec 6 '13 at 12:11
  • 1
    @Mart You could also switch Photoshop to basic rendering mode. Especially if you are not doing anything intensive, I would recommend that. (I was actually researching this recently [laptop with switchable graphics, random PS flickering], and others have said that worked for them.) – Bob Dec 6 '13 at 12:54
  • @Bob, this is probably so useful it should be an answer instead of hidden in a comment? The OP never actually asks a question, yet IMO this is a better answer than mine! – Dave Dec 6 '13 at 12:58
  • DaveRook I'm actually not 100% sure it will work - the problem this fixes may be a related but not-quite-the-same issue with graphics drivers on Windows 8. It certainly won't hurt to try. (@Mart please let us know if it works! Also try fully disabling GPU acceleration, rather than just basic mode.) – Bob Dec 6 '13 at 13:14
2

Following on from Dave Rook's answer that Photoshop doesn't really work with multiple GPUs - and this is especially apparent with switchable graphics - you can try to turn GPU-accelerated rendering down to Basic or turn it off entirely. There may be a slight performance hit, but as long as you aren't doing anything intensive and/or can afford to wait a bit, this might be preferable over removing a monitor.

To disable GPU acceleration, untick Use Graphics Processor (mentioned in step 2, perform the opposite action by unticking it). To switch to Basic mode, change the option mentioned in step 3:

GPU/OpenGL preferences in Photoshop CS6

The advantages of using a compatible video card (GPU) with Photoshop are that you can experience better performance and more features. Problems can occur if you have an older video card with limited VRAM. They can also occur if you use other programs that use the GPU at the same time as Photoshop.

  1. Choose Edit > Preferences (Windows) or Photoshop > Preferences (Mac OS).

  2. In the Performance panel, make sure that Use Graphics Processor is selected in GPU Settings.

  3. Click Advanced Settings and specify the following options:

    Mode > Basic Uses the least amount of GPU memory and enables basic OpenGL features.

    Mode > Normal Uses more GPU memory and enables GPU-based color matching, tone mapping, and checkerboard blending.

    Mode > Advanced Provides the benefits of Normal mode as well as newer OpenGL advances that can result in improved performance.

    Use Graphics Processor to Accelerate Computation

    Use OpenCL Uses the GPU to accelerate the new blur filters (Field Blur, Iris Blur, and Tilt-Shift). OpenCL is only available on newer GPUs that support OpenCL v1.1 or later.

    Anti-Alias Guides And Paths Allows the GPU hardware to smooth the edges of drawn guides and paths.

    30-bit Display (Windows only) Allows Photoshop to display 30-bit data directly to screen on video cards that support it

0

seems to be a common issue, I've found this solution as I describe in this post:

I had some similar issue but with the Photoshop crashing all the time with the dual adapters bug and I found a solution that might help you:

  1. Before opening Photoshop go to My Computer > Manage > Device Manager and disable the Display Adapter that you don't want to use
  2. Open Photoshop and check in Preferences > Performance if the wanted display is selected.
  3. If the Adapter is correctly selected re-enable the disabled one from the Device Manager

this is annoying but does the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.