0

I have file sharing enabled in Windows 7 64bit to access files over the local network. I have used it for years to move files to and from my phone (using an File Expert that supports SMB) and access media on my Wii using homebrew.

Yesterday it suddenly stopped working with no apparent cause. I cannot connect to it from either the Wii or File Expert. I do not have another Windows machine available on which to try it, but if I type in the network address on the computer itself (//COMPUTER_NAME or //COMPUTER_IP) it acts like it is working. It seems unlikely that both devices failed at the same time so I'm pretty sure it's the computer. I've tried restarting and running Microsoft's "Incoming Connections" troubleshooter but it did not solve the problem.

I'm not even sure where to look further or what to try.

Edit: This is embarrassing but it turns out the problem is with File Expert. WiiMC defaults to the location you were looking at when it last closed. It seems that means it will bring up the previous message. If I had dismissed it and tried again without restarting the Wii I probably would have noticed it works. So it failed at some point but is not an ongoing problem.

So not fully fixed but now I have a much tighter window of things that could be wrong. (especially given I just updated my Galaxy S3 to Android 4.3 so I even have a clear cause)

  • Did you try disabling the firewall alltogether? – Lieven Keersmaekers Dec 6 '13 at 20:21
  • That wouldn't be a permanent solution but I did try it to see if it is a firewall problem and it didn't work (so I cut it back on). – Fr33dan Dec 6 '13 at 22:16
  • What 'type' of network connection is showing if you right click on the network icon in the system try, choose "Open Network and Sharing Center" look under Active Networks? Is it set to private, public or work? If it is anything other than Work, you will have issues with accessing shares on your local network. – Richie086 Dec 6 '13 at 22:30
  • @Richie086 It is Home, but it has always been Home (I thought Home was the most "open" option). I tried changing it to Work just in case and there was no change. – Fr33dan Dec 6 '13 at 22:46
  • Are you connecting to the internet with the Wii via WiFi or do you have one of those ethernet dongles that hook up via USB? – Richie086 Dec 6 '13 at 22:58
1

First suggestion is make sure you're using the correct slashes, dunno if that'll change anything but might depending on the application. Second suggestion is try navigating directly to the share (i.e. \MYMACHINE\ShareName)

Some problems like this are also often associated with DNS hiccups. There's a couple possible points of failure 1) Your router 2) Your mobile device

Assuming you're using an android, if that's the case, try using a terminal emulator to ping the computer name and/or IP. If this is coming back invalid then you'll wanna try resetting your router and flushing your device dns. If that isn't the case or that doesn't help then try checking the share. Do this by right-clicking on My Computer (either on the desktop or in the start menu) and going to "Manage". Once open, switch to the shared folders and make sure that the share still exists. Second, if it does, check to see if there's any existing sessions open. If there are, disconnect them. Try connecting again. If that still doesn't help them try recreating the share.

ADD: I personally would not recommend disabling the firewall as that just opens up a world of possibilities you don't want.

| improve this answer | |
  • The way both File Expert and the Wii are configured make incorrect slashes impossible. File Expert does not allow you to specify a share before you connect but the Wii requires it. I am also configuring them using the IP address directly so I don't think DNS comes into play here. Either way it did not work. And I'm sure he just meant diagnostically; turning the firewall off is not a permanent solution. – Fr33dan Dec 6 '13 at 22:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.