3

I've done a lot of diagnosis and I think I have the problem pinned down well enough. I just don't know where to proceed from here.

My parents have my old Dell desktop computer (XPS 410, if you're curious). It works solidly enough, and never has had any issues. I've even done a few upgrades within it for the memory, video, and hard disk drive storage. However, of late, it's starting to have intermittent USB failures. All USB devices work fine themselves, but the computer will start failing to properly initialize them. It doesn't matter which port they're connected to or whether they're front panel or back panel. Typical behavior is some ports will not initialize at all, and some will, but while logged into Windows, will stop working for periods of time, before starting again (if at all).

I didn't find any driver issues, and I've ruled out anything within Windows in general, as I even experience loss of communication with the keyboard during POST and within the boot menu (it dual boots Windows 7 with XP for an old scanner that doesn't work with Windows 7).

What I then tried was cleaning out any dust buildup within the machine. I hadn't done so for this computer in a while anyways, so it was a good place to start, and I have fixed other strange hardware failures with such maintenance, anyway. I unplugged it, grabbed my compressed air and a vacuum, and went to town. There was a lot of dust, and I made sure to get as much of it as possible. After plugging it back in and booting up, things seemed to be fine again.

Everything was ok for the next few days, and then the same thing started happening all over again. Usually my parents experience it with the mouse ceasing to respond for seconds at a time, seemingly at random, while they're doing work. Eventually the keyboard stopped working completely, even after a full reboot. It couldn't be dust as I had recently cleaned it up, so while I was unable to work on it at the time, my father unplugged it for a while and then plugged it in again, and booted. Everything was working again.

At this point I believe that the dust was a red herring. Unplugging it for a while lets any residual charges ground out, and as I did this while cleaning the dust out, I believe this was the real "fix". However, it's impermanent. My thought is that somehow there's extra electrical charge, static or otherwise, that's accumulating in the USB root hub(s) and not grounding out properly as the computer is plugged in. This could explain universal USB failures, their intermittent nature, why unplugging the computer for a while "fixes" it, and why it took a few days for the computer to start again exhibiting this strange behavior after I cleaned the dust out of it several days ago.

So now I'm not sure what my next step would be. If it's a grounding issue, how can I resolve this? Is it simply environmental static buildup? Winter did recently start, which means dry air, and lots of static cling. The computer tower is properly ventilated, but is sitting on the floor under the computer desk, which is on top of a plastic mat over medium pile carpet. The plastic mat isn't antistatic, so we guessed that it's gathering static from the computer chair, feet, and people's nightrobes or other clothing brushing against the chair, computer tower, floor, and desk every night (as my parents use the computer daily).

Would the solution be simply to get an antistatic mat to set the computer on? Or put the tower on a platform above the floor? It won't fit on the desk. Or is there a different fix that's appropriate and would involve some internal maintenance to the computer? I do not want to recommend buying a new one as it's both expensive and the computer otherwise works perfectly fine when it's not having this issue.

2

Although I can't be absolutely certain that I know a fix for this, I once had a problem with a Gaming desktop PC and USB port grounding.

I won't go into the specifics but basically a live part of the power supply wasn't in place correctly and was causing anything attached to the case to short (over-current) and stop working. The bios would report this on boot up though.

What I'm thinking is that something has broken in the power supply that is possibly randomly shorting the USB ports (since they are metal, and normally attached to the metal case). Maybe try taking the power supply out and checking for damage (computer could have been knocked and something may have got loose). If you don't see any problem, maybe check that the case hasn't suffered any damage in that area on the inside of the PC.

Final bet (and what worked for me): replace the power supply. If your computer is old, it's a possibility that the supply has become faulty (everything becomes faulty over time). Another possibility is that some other internal part of the PC (the motherboard most likely) is scratched or is touching something it shouldn't.

Personally, I suggest getting a new barebones PC and re-using some of your previous hardware. However, modern motherboards use UEFI which forces you to use Windows 8 and fresh Windows 7 installs (as dual boot. You can't uninstall W8 and replace it with W7 easily, if at all). This also means you can't just shove your old hard drive in and use your old W7 and XP dual boot with a new motherboard. If that is a problem, maybe just buy a new case and migrate motherboard over too. If you do that, I definitely recommend getting a case + power supply (of the same/slightly higher wattage of your current supply) combo since you should regularly replace parts like that anyway (but check that the power supply hasn't just been randomly jammed in there like mine was!).

GLHF

  • 1
    I haven't done a full in depth diagnostic of it, but we have since moved the PC into a different part of the house and it is no longer in such a high-static area. I haven't seen the USB issues since. I think that it probably was the static causing some issues with the USB controllers. – Ben Richards Jun 16 '15 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.