89

This question already has an answer here:

I've got a slightly annoying problem. My locale is English (UK), but occasionally my keyboard randomly switches to English (US) on Windows 8.1. I see that the task bar has a language selector, which when I click on it displays two languages:

Most of the time it stays on UK, but occasionally randomly switches to US. When I go into the Language section of the control panel, only English UK exists:

In Advanced Settings I've specifically set the input method to be English (UK), but English (US) persists in its obstinate existence.

Why is the 'US keyboard' there? How do I get rid of it?

edit There is only one language listed under 'input settings':

marked as duplicate by Ƭᴇcʜιᴇ007, Kevin Panko, Nifle, DavidPostill, Matthew Williams Nov 24 '14 at 8:59

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You may leave UK language, but change its keyboard to US. – T.Todua Jan 5 '16 at 19:01
108

I understand your frustration. This will work!

Control Panel > Language

If 'English (United States)' is not a visible option then re-add it by clicking 'Add a language'

Once added click 'options' on the US language and add an input language.

Add the United Kingdom input method.

Remove the United States input method.

go back to 'Change your language preferences' and remove the English (United States) language you had added.

Hopefully Windows updates will fix this soon.

  • 2
    This will also remove the 'ENG' tab from the taskbar. – Amit Jan 23 '14 at 15:31
  • 1
    I had exactly this issue (only UK English listed in the settings, but US English appearing as well in the taskbar) and adding, then removing US English within the settings worked for me. – Tim Radcliffe Mar 26 '14 at 7:14
  • It works! It is very strange though - It doesnt make any logic to me as to why adding a whole other input and removing it should do this. But thank you! – Chud37 May 25 '14 at 9:03
  • 1
    Lol Windows will never stop suprising me :D Thanks! – sczdavos Jul 23 '14 at 11:41
  • 8
    This also works for Windows 10 – Robin Aug 10 '15 at 19:20
9

The right answer to the question «How do I remove automatically added keyboard layouts?»:
https://superuser.com/a/484595/128312

2

this may also help - though it may be a variation on a theme (of Amits answer). I'd tried all the other options - but to no avail - English (United States) kept reappearing on the list and the keyboard input was US.

This worked for me: Changed Control Panel to Large Icons (rather than Category - my preferred Mode)

Selected Language.

From the Change your language preference window (which showed both UK and US English). Selected English (United Kingdom) Then Options / Add an input method. I then selected United Kingdom Extended. (I already had the United Kingdom). It selected the new one ok.

Then back to previous Change your language preference window. Selected English (United States) and then Remove. It removed it - this time permanently.

I then rebooted and the correct UK Keyboard input method was working (Pressing @ got @ not ")

A very odd and convoluted process to get an essential result.

  • This worked for me too on Windows 10 – Klors Feb 8 '16 at 10:49
1

To remove a language via IME (Input Method Editor) :

Go to All Control Panel Items > Language > Language options.

There you can see Input Methods. Remove the US Keyboard from there.Hit save. voilà.

Update :

Since there is no input method other than UK English , I have to assume that there may be some program that requests the US English Keyboard layout ( Programs like icq are claimed to do that ). Or it may be due to Microsoft Office IME running on startup.

I personally do not know much about this issue since I use the US Keyboard layout by default.But, I think that you might have to give a try for the solutions listed here for a similar question in Windows 7.

  • I updated my question - I think I got the same dialog you're referring to, and there's only 'United Kingdom' listed under 'Input method'. – growse Dec 7 '13 at 9:35
0

I am having the same problem

I have a solution, but it's not a permanent one.

You need to add the specific keyboard layout that your computer seems to have added by itself, then click apply.

After that you need to remove that specific keyboard layout and click apply, the language bar should now be gone and you should not be able to switch to ENG US anymore.

0

Still not fixed by Windows Update as of today... This problem seems to occur only on machines that have been upgraded from Windows 8 to Windows 8.1, though I'm not 100% sure of that.

The solutions above didn't work for me. My keyboard layout was stuck on English (US) and my keyboard is in Dutch (Belgian Point).

How I fixed it:

  1. Open configuration panel > language
  2. Open the options for English (US) (I cannot delete this entry, it's always back after closing and opening this settings screen again)
  3. Add the keyboard layout you want to English (US)
  4. Delete the existing keyboard layout, this should be English (US)
  5. Save the settings
  6. Switch the keyboard layout using the charms bar > settings or another method to the input method you need.
-1

I suggest going to the Advanced settings menu and take a look at the 'Apply language settings to the welcome screen, system accounts and new user link'. I changed all the options to read English (United Kingdom) - United Kingdom, copied them to the Welcome screen, system account and New user account and thankfully now have no sign of any option to select the US layout!!!

Not the answer you're looking for? Browse other questions tagged or ask your own question.