1

On a Dell Optiplex 755, when I bring the system out from ACPI S3 (suspend) to S0 (normal running mode), the system stays on for perhaps 10 seconds, maybe more. Then it very suddenly shuts the power completely off.

I have tried three different BIOSes, (I do not remember the first, but A21 and A22, with A22 being the latest available and the one I am using now). I am running Slackware on this system, I have tried 13.37 and 14.0. I have tried different kernels, but mostly I use custom compiled ones.

I have tried looking at the BIOS settings. There is a setting there to specify what the computer should do when "AC power is restored". It can either "stay off" or "stay on" (perhaps phrased in different words in the BIOS itself though). Is this related? This sounds like what would happen if I yank the power cord out and put it back in, not what it should do when it moves between ACPI states in a controlled manner.

I enter S3 by issuing "echo "mem" > /sys/power/state" or by selecting "Suspend" from XFCE's shutdown menu.

I enter S0 by physically pressing the power button, which at the time is blinking to indicate the system is indeed suspended.

  • The BIOS offers a feature to specify that "suspend" should be S2 ("standby") or S3 ("suspend"). If S2 is selected, the system does not power off when it resumes. However, this obviously has the problem that it consumes more power. I am at a loss for how to proceed from here. – AttributedTensorField Dec 20 '13 at 8:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.