19

Recently, my install of Chrome (currently version 31.0.1650.63 m, win 8.1x64) has been opening images from sites such as imgur in their full resolution glory and not resizing to fit the screen as it a) used to and b) IE/FF continue to do. I noticed this about a month ago from opening imgur links from Reddit and this afternoon, it finally bugged me enough to seek out a solution.

I am sure there is a setting(?) but I cannot find much help in what would have caused this and how to remedy it.

Chrome:

enter image description here

IE 11:

enter image description here

3
  • Have you tried resetting chrome to default or reinstalling it?
    – user201262
    Commented Dec 7, 2013 at 20:25
  • @Moses - I have not, not a bad idea. I think it happened shortly after the Win 8.1 update, so that could explain a few things
    – Tommy
    Commented Dec 7, 2013 at 20:27
  • @Moses - that did it - can't believe I didn't think of the reboot method. Add as an answer, ill accept.
    – Tommy
    Commented Dec 7, 2013 at 20:32

3 Answers 3

2

You can reset Chrome's to defaults in Advanced Settings:

enter image description here

Or you can try re-installing Chrome, which should do the same thing. There is no setting option for image re-sizing, it is likely a bug you are encountering from the upgrade to Windows 8.

3
  • LOL, I have had this problem earlier today only with THIS site... I had to re-install Chromium, after cleaning up all the mess left behind by a purge uninstall Commented Dec 7, 2013 at 21:51
  • This did not work for me.
    – Xonatron
    Commented Jan 23, 2015 at 6:20
  • Actually it did work, I had to reset the zoom back to 100%, even though I had no idea it was set to something other than (such as 400% or something).
    – Xonatron
    Commented Jan 23, 2015 at 6:22
21

Try pressing Ctrl+0 or Command+0 to reset your zoom to 100%. (That 0 is a zero, not a capital "oh".)

7
  • 1
    (1) Can you provide any reference documentation to support this answer? (2) This may actually be an anti-answer. From my reading of the question, the problem is that the browser opens images in full (100%) size, and the OP wants a way to tell it to shrink to fit. Commented Mar 6, 2015 at 7:16
  • 5
    Yes, this is actually the right answer. I had, at some point, zoomed in on a single image. Even though my general browser was not zooming, it was handling all subsequent images that way. CMD-0 on my MacBook fixed it. Many thanks... Commented Dec 22, 2015 at 21:50
  • 2
    @G-Man 1) It's a basic function of Chrome that allows you to reset the zoom level, akin to CTRL+L to focus and highlight the text in the address bar. 2) How is an answer an anti-answer? 3) I had the same problem and it fixed it for me, so it is a fix for some.
    – Josh
    Commented Mar 14, 2016 at 19:33
  • 2
    +1 This is an amazing answer... I had this problem for months thinking it was a Chrome bug but this was it... on normal pages it's easy to understand if you accidentally aren't in 100% but on images it's very hard to understand. Of course the accepted answer also works because it resets everything but this should be the accepted answer.
    – AlfaTeK
    Commented Jun 3, 2016 at 16:27
  • 3
    This worked for me. It's interesting that Chrome seems to remember zoom settings based on content-type? This issue was affecting only JPEG images. PNG was unaffected. Commented Jan 31, 2018 at 5:34
2

On Mac OS X, by default Chrome doesn't resize a single-image page to fit the viewport (at least as of version 44.0.2403.155, August 15 2015). Instead it displays the image with its full native resolution. If you want Chrome to resize all single-image pages that you visit, you'll need to install an extension such Image Autosizer. Without an extension, your best bet is to click on the image once to enable the "zoom" tooltip. Then clicking the image a second time should zoom out such that most of it fits on the screen. Here's a large image that you can use to test this.

4
  • As far as I know, your information is not correct. I am on the version that you referenced, Win10 x64, with only ad block plus and Google Docs installed, and the image you posted opened in "fit the window" mode. Also, the "zoom" tooltip was available as soon as I hovered over the image (no clicking needed). The solution marked as correct worked in my case (as Chrome used to auto fit images, then stopped. A reinstall fixed this). Perhaps you should try a reinstall as well and see if the behavior works as intended for you after that.
    – Tommy
    Commented Aug 15, 2015 at 16:07
  • 2
    Perhaps the behavior is OS-dependent. On Mac OS X I'm 100% sure it behaves as described in my answer because I wiped my hard drive and did a clean install of the OS and Chrome. That's how I ended up here. I remembered having "fixed" the issue previously but couldn't remember how. I've edited my answer to specify OS X. Commented Aug 16, 2015 at 20:07
  • Good to know! Yeah, I have no idea about OSX behaviors...
    – Tommy
    Commented Aug 17, 2015 at 16:01
  • I can confirm that this resolved the issue on OSX & Chrome 47.0.2526.73 (64-bit) Commented Dec 9, 2015 at 16:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .