1

I have a new ASUS X552C laptop. It is working like a charm, but I ran into a problem when I decided to install Linux Mint. It seems like my Atheros AR9485WB-EG wireless card is not recognized by the kernel! It works very well on Windows 8 but not on Linux.

On the Panel the wireless switch is always off and can't be turned on.

I really don't know what the problem is? Shouldn't it be supported?

Any suggestions about how to get my wireless working in Linux Mint?

7
  • What happens when you modprobe ath9k and then reinsert the card? Dec 7 '13 at 22:19
  • nothing !,but what do you mean by "reinsert the card" it's laptop ,it's built-in !
    – wisdom
    Dec 7 '13 at 22:26
  • Let us continue the discussion in chat Dec 7 '13 at 22:48
  • I just have some clues to solve it :), I'll try and post here. until tomorrow sorry I'm so tired ,thanks
    – wisdom
    Dec 7 '13 at 22:58
  • Are you still interested in this? There is a solution to this problem. Dec 8 '13 at 8:30
2

While I am trying all possible combination keys to turn on wireless I found the following:
On my keyboard F2 has the wireless tower symbol and that is not working when I press Fn+F2. However,F1 has 'Z' symbol referring to snooze state so when I tried it Fn+F1 laptop goes to a quick snooze and when press power button to wake it up, voila wireless is working ! and I should do that every time booting into Linux.
I don't know what is happening but that is it, anyone can give a further explanation ?
So then its driver is OK on Linux I guess

3
  • Can confirm I'm also seeing this on an Asus X552C. At first, wifi is inoperative, Fn+F2 does nothing, and rfkill shows phy0: Wireless LAN as Hard blocked: yes; but after Fn+F1 (suspend) and a wake-up, rfkill no longer lists any blocking, and wifi works just fine. I'm using a fresh Trusty Tahr install, and lshw reports that this has ath9k driver version 3.13.0-24-generic. May 19 '14 at 2:07
  • Great temporary fix! I found (somewhere) a guide which said to add-to (or create) /etc/modprobe.d/asus.conf and then add this line: options asus_nb_wmi wapf=1 and this fixed it permanently
    – xxjjnn
    Jun 12 '14 at 16:03
  • I dont know how and why but that also really worked for me. But I couldnt make it consistent. When I run lsmod before and after sleep/woke the differences are ccm and ctr modules loaded after and aesni_intel s used param become 2.
    – alpert
    Oct 30 '14 at 21:03
1

The most likely cause of your problem is the lack of an up-to-date version of your driver.

If you search for Atheros AR9485WB-EG on WikiDevi you reach this page where you are told you need as a driver ath9k from backports. This means your version of ath9k is most likely outdated, and we must install a new one. I'll walk you through it.

Make an empty directory, get into it, then issue these commands:

   sudo apt-get install linux-headers-generic build-essential 
   wget http://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.12.2/backports-3.12.2-1.tar.bz2
   tar xvf backports-3.12.2-1.tar.bz2
   cd backports-3.12.2-1
   make defconfig-ath9k
   make
   sudo make install 

Turn the pc off and back on, it should work. If it does not, (unlikely, but never mind), issue these two commands:

  sudo rmmod ath9k
  sudo modprobe ath9k nohwcrypt=1
7
  • I tried as you said but while making install there are some errors -here is a snapshot s30.postimg.org/foq6v7lcx/… -, is it failed ? nothing worked yet but my solution fn+f1 !
    – wisdom
    Dec 8 '13 at 15:37
  • It worked. You will have to reboot. If it still does not work, add the follwoing command: sudo rfkill unblock all. Dec 8 '13 at 15:39
  • I did but still can't switch it on :(
    – wisdom
    Dec 8 '13 at 15:41
  • as I noticed of command rfkill list says phy0:wireless LAN hard blocked:yes
    – wisdom
    Dec 8 '13 at 15:44
  • just it seems such type of network card has a bad support on Linux, hasn't it ? any hope to solve this problem ?
    – wisdom
    Dec 8 '13 at 18:01
0

Wifi is hit-and-miss in Linux unfortunately. I realise that this is a long shot but have you tried something like the following?

sudo ifup wlan0

Usually though, in Linux Mint, if there are additional drivers available, then the Menu -> Preferences -> Additional Drivers utility will tell you about it. If it finds it there then you will obviously need to plug in wired to install it.

If that doesn't help I'm afraid I can't offer much more suggestion... I have a bit of experience getting wifi to work on desktops but none with that specific card.

1
  • actually I tried such command ifup -a but nothing at all ! and when I tried this one it says no wlan0 ! as it has no driver !
    – wisdom
    Dec 8 '13 at 14:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.