0

I use an SSD as my boot device, and I have a HDD that I use for data. Both drives are set up using GPT/UEFI. I installed CentOS to its own partition on the HDD, and I have Windows 8.1 installed to the SSD. When I installed CentOS, it gave me a warning that said something to the effect of "WARNING! You are using GPT with a non-EFI system. This may or may not work, depending on your BIOS."

I booted into the live DVD using my UEFI settings, and during the installation I told CentOS to install the bootloader to my SSD. The system still boots directly into Windows, however--it appears that no bootloader was actually installed. I tried installing rEFInd, but it did not detect CentOS. My mobo's fast boot and Secure Boot options are all turned off.

I'm not familiar with how EFI works for booting, and I cannot figure out how to easily dual-boot Windows 8.1 and CentOS 6.4. I would love to use Fast Boot and only boot to CentOS whenever I specifically tell it to (ignore the bootloader entirely unless I use a keypress or something during boot; having to disable fast boot altogether is also okay since I'll rarely use CentOS), but that's probably not possible.

Basically, I can't get my EFI system to detect my CentOS installation to allow me to boot to it, and I'm not sure what to do. Any help would be greatly appreciated!

0

Disable secure boot and consider using legacy bios mode if your CentOS doesn't have efi support built in to the kernel.

0

It sounds like you've got an EFI/UEFI-mode installation of Windows and a BIOS/CSM/legacy-mode installation of Linux. There are basically three ways to cope with this problem:

  • Use your firmware's boot manager -- Most EFI-based computers have boot managers, many of which will let you switch between EFI-mode and BIOS-mode boot loaders. You can usually get into this boot manager by hitting Esc or some function key early in the boot process. Unfortunately, some computers have such poor boot managers that this option won't work with them; and even when it does work, many users find it awkward because the window of opportunity for entering the boot manager at boot time is usually just a couple of seconds.
  • Use rEFInd -- My rEFInd boot manager is an EFI-mode boot manager that can launch a BIOS-mode boot loader. To do this, you'll need to install rEFInd under Windows and edit refind.conf to uncomment the scanfor line and add hdbios to its list of boot options. The result should be a new diamond-shaped gray boot icon, which should launch Linux. As with the previous option, though, rEFInd doesn't work on all EFI-based computers, so I can't promise this option will work; however, rEFInd is one of the specific solutions for the next option, too, which can make it a good way to try two solutions at once.
  • Install an EFI boot loader for Linux -- You can install any EFI-mode boot loader for Linux that you like. Quite a few are available, so take your pick. I recommend you focus on GRUB Legacy or GRUB 2 (whichever CentOS uses for EFI-mode installs) and rEFInd; but ELILO, SYSLINUX, or gummiboot might work fine, too. This approach is the most likely to work, although you'll need to learn enough about how to do the installation to get it working, and you'll also need to either install the boot loader in Windows or get an EFI-mode emergency Linux boot working. Note also that re-installing Linux, using an EFI-mode boot of the installer, is one way to accomplish this goal. That's a radical solution in some ways, but since it's a fresh install, it's worth considering if you can figure out how to get the CentOS installer to launch in EFI mode. (See my page on EFI-mode Linux installations for more on this topic.)
  • This is a phenomenal post, thank you! I just installed CentOS and haven't done anything with it, so I'm fine reinstalling it if need be. Is there a way to install it in EFI mode, as it seems like this would solve my problems (plus it's just cleaner to have everything use EFI)? I booted it from my mobo in EFI mode, but it didn't detect it (gave the warning about using the GPT file system on a non-EFI system). – vaindil Dec 10 '13 at 0:51
  • There's a lot of variability in how to boot an external medium in EFI mode. Many computers have a built-in boot manager that will show two options for an external disk, one with "EFI" or "UEFI" in the description and the other without it. Select the EFI/UEFI option to boot in that mode. With some, though, you have little real control. Your best bet then is to install rEFInd, which (if you don't adjust the scanfor option) will present only EFI boot options. – Rod Smith Dec 10 '13 at 3:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.