22

On my Windows 8.1 machine, I need powershell to configure office web apps.
When I start powershell, for a blink of a second, it shows as it should, but then it gets resized, and the font becomes something like 0.5 to 1mm in height.

Barely readable.
I tried adjusting the font size, and increasing the registry value for DPI, but it does not have any effect.

I cannot use a shell where I can't read the output or the input.
Anybody can tell me how to resolve this ?

I tried the screen magnifier, but the font is just that small, that when you magnify it, you canot read it either...

  • I suffer from the same issue. The font is sized to bitmap 4x6 despites I set default settings for consoles to Lucida Console 24pt. – dolmen Apr 18 '14 at 5:18
  • 1
    This is probably a permission issue. This question may have useful answers to solve our problem. – dolmen Apr 18 '14 at 5:26
  • Worse: typing "PowerShell" from a "cmd.exe" window that has the right settings does the resizing... – dolmen Apr 18 '14 at 6:12
  • Squinting 6 inches from the screen is part of the "ergonomic" engineering Microsoft bakes into all their stuff. It's all about keep expectations low. – Bill Westrup May 29 '15 at 17:41
34

Open an elevated Powershell ("Right-click" and "Run As Administrator"). Left click on the icon in the left hand side of the title bar (or press Alt+Space), select Properties, then on the Font tab you can select the size. "8 x 12" is probably what you want.

You probably want to select "Lucida Console" as your font as Consolas is a little difficult to read imo.

You MUST ensure you are running PowerShell elevated (as Administrator) if you want your configuration to persist permanently.

  • 7
    This works only for the current window. This isn't remembered, and the resizing still occurs, even if I change the "default" settings. Cmd.exe windows are fine. – dolmen Apr 18 '14 at 5:22
  • 1
    This worked for me - as long as it is done in a console started as administrator. Thanks! – Danny Staple Mar 1 '15 at 10:34
  • This has no effect at all – Quandary Jul 17 '15 at 10:45
3

The inability to permanently fix the dafault PowerShell shortcut is a permission/UAC issue; you can configure PowerShell any way you want (bigger/different fonts, Windows size etc.), but the settings will not be saved because, as usual with UAC, you think you have admin privileges, but you don't, and the default PowerShell link is the same for all users, thus you need admin privileges in order to modify it.

Fix: start PowerShell using "Run as Administrator", configure it as you wish, and then the settings will be saved.

I still don't understand why its default settings include astonishingly small fonts, but at least it can be fixed this way.

3

Very strange, but the only permanent solution I found is by following exactly these steps:

  1. In Windows 8.1, right-click the Start menu button and click Windows PowerShell (Admin).*
  2. Confirm the UAC prompt (if any).
  3. Click the top-left corner window icon and choose Properties.
  4. On the Font tab, select Consolas as the font. Note that Lucida Console won't work.
  5. Select an appropriate font size. I selected 14 points.
  6. Click OK.
  7. Close the PowerShell window.

This sets the font for both Windows PowerShell and Windows PowerShell from the Start menu's context menu, and for the Windows PowerShell shortcut in the Apps overview.

*) If you don't have Windows PowerShell (Admin) in your Start menu (instead you see Command Prompt (Admin)), then right-click the task bar and choose Properties. Then go to the Navigation tab and check Replace Command Prompt with Windows PowerShell in the menu when I right-click the lower-left corner or press Windows key+X.

  • The "Note that Lucida Console won't work." helped me. :-) – Ignitor Nov 13 '17 at 13:32
1

I'm using a shortcut pinned to the taskbar. Like you, changing the settings in the default window option from the window menu did not fix anything.

I've been able to change the settings for that shortcut by right-clicking on the taskbar icon, then right-clicking on Windows PowerShell in the menu (to access to the context menu of the sortcut), then Properties. The font tab has the option. However, using Lucida Console doesn't seem to work. But Consolas works!

It may also be useful to let the system position the window (Layout tab).

Note: This is unfortunately only a partial fix. PowerShell launched in other ways than from this icon still has the issue.

1

I have added Powershell to my start menu then:

  • right click > Run as Administrator
  • in the properties and the defaults, change font to Consolas 24 (or whatever size you prefer) - for some reason it does not work with Lucida
  • exit powershell and the configuration should be saved and linked to the icon in your start menu.
0

Unfortunately no other answer seem to address the fact that you do see the window with the correct settings, but only for a moment.

I suspect, but unfortunately can't prove yet, that this is some stupid mechanism that kicks in when the window is deemed "too large" by the system, so it gets "resized". It might even have something to do with high dpi settings.

Anyway, if you go through the pain of setting the window settings again as the other answers suggest, but starting with smaller fonts, you will probably be able to settle on a font/window size combo that the system somehow accepts without triggering any forced resize. This worked for me. I hope this helps.

0

For Win 8.1 On Start find PowerShell.
Open file location. Open shortcut Properties (right click menu).
Security tab -> Edit your permissions to Modify.
Select Font tab. (skip errors - nothing is set hence problem)
Select Font (I set Lucida Sans Size 16).
Apply (changes).
Security tab Edit permissions remove modify.
Apply.
All done.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.