Due to some malware attack a file named com7.ini.asp got created in my folder and it is hidden when I browse it through Windows. I tried the following:

  1. I gave the whole path in the address bar and tried. ( f:\folder name\com7.ini.asp ) it prompted me to "Open With" window and I selected Notepad and dialog box says no such file exist.

  2. When I tried attrib command in command prompt it listed com7.ini.asp file, but when I revoked permissions to that file or tried to delete that file it said path not found - \\.\com7\ . I also tried rmdir, it too produced the same error.

  3. I tried to scan it with a malware scanner but no luck.

It would be helpful if anyone has any idea on how to delete this file.

  • Sometimes files can be corrupt, have you tried running scandisk on the drive? If the file is only an aberation in the allocation table it could fix the issue. Can you display properties of the file in the explorer? (Can you see it when setting "hide system and hidden files" under Folder Options to false? – Jozef Legény Dec 9 '13 at 10:22
  • This is probably because COM7 is a reserved name - msdn.microsoft.com/en-us/library/… . Try using the dir /x command to see if you can obtain a short name that works. – David Marshall Dec 10 '13 at 0:22
  • @JozefLegény: i was not able to display the properties of that file. I can only see the file name using 'attrib' command. I'll try the scandisk and update the result – Subhash Dec 10 '13 at 7:58

I think the file needs an administrator account to be manipulated, what happens when you run command prompt as an administrator, then apply attrib command with the following switches: -a -s -r -h, and manipuate the file?...If that has fails, i think you should get the CCleaner software which repairs the system files, registry settings and it also removes corrupt and malicious files aswell, in case its a bug or something.


Run linux live CD e.g. ubuntu. Locate file and delete it.


Looks as if the filesystem got corrupt. Run chkdsk/f on the drive.


It could be the file isn't named com7.ini.asp, but has a space at the end etc. Try it with com7 (or maybe even just 7).


Just try to open hidden files from the alt+T and go to folder option to show all the files including windows . then u'll see the actual folder containing the actual data and u'll be able to delete the shortcut files too.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.