I think this issue has been going on for over a month now.

I boot my PC and the Adobe Updater tells me to download a new version of Flash. It sends me to https://get3.adobe.com/flashplayer/update/plugin/ with the following information visible:

Version 11.9.900.152

Your system:

Windows, English

The Update Now button simply links to http://www.adobe.com/

screenshot with freehand circles

  • I've cleared my cache, that didn't help.
  • The Are you an IT manager or OEM links me to a page where I can either Apply to distribute Flash Player or Download Adobe Flash Player, the latter just sends me back to where I came from.
  • I've uninstalled and rebooted, went to the Adobe website and clicked Adobe Flash Player under the Download menu. The Install now button again links me to http://www.adobe.com/
  • Need Flash Player for a different computer? sends me to http://get.adobe.com/flashplayer/otherversions/ and the Download now button is greyed out and unclickable.

How can I update?

  • So far you've just stated what you see, but not included what you've tried or where you're getting stuck. Have you cover the basics? Have you tried clearing the browser's cache? Have you tried uninstalling and then reinstalling Flash? Have you tried using the full installer (the "Are you an IT manager or OEM" link should help you get that)? – Ƭᴇcʜιᴇ007 Dec 9 '13 at 18:04
  • @techie007 I'd say I'm stuck at the updating part. I haven't tried uninstalling and reinstalling, I'll do that now. Regarding the other two questions, I've updated my post. – Stijn Dec 9 '13 at 18:08
  • @techie007 I've uninstalled and now I cannot install Flash at all, see the edit. – Stijn Dec 9 '13 at 18:12
  • What version of Flash do you currently have installed? – Ramhound Dec 9 '13 at 18:16
  • Have you tried a reboot after uninstalling it? BTW: If you "apply to distribute flash player" you can get your hands on the full installer. You just have to fill that form out to get it, not pay money or anything. ;) – Ƭᴇcʜιᴇ007 Dec 9 '13 at 18:16

The cause of the issue was the Ghostery addon for Firefox. Pausing the blocking gives me a proper URL to download the installer.

On http://get.adobe.com/flashplayer/otherversions/ a few dropdowns appeared after pausing the blocking letting me pick an OS and a version.


You can download the Flash installer from the Flash Player - Different Versions (http://get.adobe.com/flashplayer/otherversions/) page.

Make sure to select your OS and browser from the list.

  • I was about to add (I've just rebooted), I had found that page but the button is greyed out and I cannot click it. – Stijn Dec 9 '13 at 18:20
  • 1
    Did you select the correct version on the left? – Johntor Dec 9 '13 at 18:26
  • 1
    See my answer, apparently Ghostery was blocking that part. Thanks for trying to help! – Stijn Dec 9 '13 at 18:27
  • Ok let us know the result – Johntor Dec 9 '13 at 18:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.