1

Whenever full screen video is playing, for instance, youtube, twitch, VLC or XBMC, sleep is prevented, but it seems like the idle timer still ticks down to zero which means the minute the video ends, the computer almost immediately goes to sleep.

I'd like to change this behaviour so that instead of simply preventing sleep, the idle timer should be reset.

Running windows 8, with "Hybrid sleep" enabled.

My current power settings are:-

  • Sleep
    • Sleep after: 30 minutes
    • Allow hybrid sleep: On
    • Allow wake timers: Enable
  • Multimedia settings
    • When sharing media: Prevent idling to sleep
    • When playing video: Optimise video quality
  • Thats’ not how the power-management works. When a software like a video-player runs, it blocks the power-management from working at all; the timer should not be running at all. Your questions says that it sleeps minutes after the video ends, but also that it happens almost immediately. Which is it? How fast does it happen? If it really does happen minutes later, then you should check how long your system is configured to wait before sleeping; it may be an unusual number that is making it look like something strange is happening. – Synetech Dec 22 '13 at 16:25
  • 1
    @russ: Could you please run powercfg -energy and post the results. – harrymc Dec 22 '13 at 20:14
  • @harrymc Thanks for the response, the HTML output file can be found here: link – russ Jan 2 '14 at 20:31
  • @Synetech Approximately one minute after the end of a long youtube video, or a VLC video, or any other content that ends without user interaction, the computer will go into standby mode. This is definitely not the same behaviour as if I leave my computer idle. This is the same mode as Standby from Windows shutdown dialog. – russ Jan 2 '14 at 20:35
  • 1
    This is an interesting case, but you’ll need to perform a few diagnostic tests to figure out what the problem is. • Define “approximately one minute after the end of a long youtube video”; use a clock and calculate exactly how long to the second, also check if it always the same amount of time • Does it happen only after long videos? How long? What about shorter video? • What happens if you happen to press a key or move the mouse during the video? • Check the Event Viewer to see the reason for the last sleep event. – Synetech Jan 3 '14 at 1:31
1
+25

Try these steps:-

  1. Go to control panel and power options.
  2. Select the Power plan currently active or select the one you want to use and click Change plan settings.
  3. Select Advanced settings.
  4. Go to Multimedia settings and select your preferred settings.

Basically for your requirement you need to choose Optimise power settings under When playing videos.

  • My current settings in this dialog are: When sharing media: Prevent idling to sleep When playing video: Optimise video quality – russ Jan 2 '14 at 20:37
  • Does the problem still persists? – Hunter Jan 3 '14 at 6:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.