2

Today I encountered a problem with jwhois.

The problem is that it doesn't respond at all. It just queries the given or predefined host and gives no other output after this. Here are a few examples:

18:39:22 schwarz@f455-5:~ $>whois google.com
[Querying whois.denic.de]
^C
18:39:58 schwarz@f455-5:~ $>whois -h whois.denic.de -- "-T dn google.com"
[Querying whois.denic.de]
^C
18:51:21 schwarz@f455-5:~ $>whois -h whois.webhosting.info google.com
[Querying whois.webhosting.info]
[Unable to connect to remote host]
18:54:58 schwarz@f455-5:~ $>whois -h whois.internic.net google.com
[Querying whois.internic.net]

As you can see, I also tried a few other hosts I found online, but it didn't work at all. Might be useful to know: I'm sitting in the facility of a university, though I have no influence on the firewall or everything like that.

2

It may be blocked in your universities firewall, whois uses port 43 TCP by default.

Unless you can find a whois server that uses port 80 (depending on the firewall it may even block that) it might be best to use a web based whois service such as http://who.is/.

Perhaps test with another computer somewhere, if you can use telnet run:

deb:~# telnet whois.denic.de 43
Trying 81.91.170.6...
Connected to whois.denic.de.
Escape character is '^]'.
% Error: 55000000007 Request not clearly specified
  • Okay, i tried around a bit and it seems, that Port 43 is blocked by the network security. I got it to work via a different host, -p 80 and then using grep to get the required information. But it's much easier via browser. – user3060129 Dec 11 '13 at 9:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.