1

My clock gadget has been working fine for over a year since I installed Windows.

Now the clock gadget's hands have started to pivot from a position that is centred horizontally but not vertically.

When the minute hand is between around 20-40 minutes, this causes it to go beyond the edge of the clock. This causes a pink rendering artifact to appear.

In the following image, I have enabled the seconds hand so I can demonstrate the problem without having to wait until it happens again or adjusting my system time:

enter image description here

Things I've tried, with no success:

  1. Removing it from desktop, rebooting, then re-adding
  2. Uninstall the "Windows Gadget Platform" from Windows Features, re-installing it and re-adding the clock
  3. Running sfc /scannow to check for damaged system files (none found)
  4. Disk error check (none found)

I haven't installed any new software or drivers recently, only Windows updates.

  • Are you running legit copy of windows? – tumchaaditya Dec 11 '13 at 0:00
  • @tumchaaditya Yes. – rwm Dec 11 '13 at 12:17
0

IE11 is the culprit. The gadgets apparently use the explorer rendering engine. If your desktop uses anything but 100% resolution, the gadgets will be drawn incorrectly.

  • Yep, just tried it now and it draws fine when the Windows text size is 100%. I had mine on 115%, but the resolution was 100%. – rwm Jan 5 '14 at 18:03
0

The display scaling can be disabled for each gadget in its XML config file. The locations are either C:\Users\<your user name>\AppData\Local\Microsoft\Windows Sidebar\Gadgets or C:\Program Files\Windows Sidebar\Gadgets

Open gadget.xml (inside the "gadget name"\"language code") subfolder with a text editor and look for the line (autoscaleDPI)(!--_locComment_text="{Locked}"--)true(/autoscaleDPI). Replace the true with false and save the file. The gadget has to be closed while editing the file.

Source: http://winaero.com/blog/fix-gadgets-displaying-broken-in-windows-8-1-or-windows-7-with-ie11/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.