I'm using Ubuntu 13.10 on a pretty new ASUS N550jv laptop.

When I was using kernel linux-image-3.11.0-11 everything was quite well (kinda..), however, when I updated the kernel using the automatic update, the kernels which were released afterwards (12+) were faulty on my machine, and caused the battery not to be charged and only stay at their current charging level (even when the machine was off!)

The only fix I had was to roll-back to the '..11' version (on boot screen - advanced options), and hard-reboot (AC cord disconnected and reconnected) but now version 14 was released and "pushed away" the good old version 11.

How can I fix that?? Please help me...

  • Are you absolutely certain the latest kernel image is causing this issue? Have you checked your charging cable is plugged in properly and the battery is not loose? Charging is vendor/firmware specific and is not dictated by the OS installed on your laptop. – DanteTheEgregore Dec 11 '13 at 15:51
  • It's not only the latest kernel. This is a "known issue" for me... Every kernel update (after the initially 11) had the same problem and only after switching back to version 11 the prob was solved. – OBY Trance Dec 11 '13 at 15:55
  • What bios version are you on? Have you tried updating to the latest version made available by Asus? – DanteTheEgregore Dec 11 '13 at 17:01
  • Upon further investigation it appears there are many other documented cases of this and similar issues. It appears to be a hardware or firmware issue that is, in fact, somehow being aggravated by one or more versions of the Linux Kernel. – DanteTheEgregore Dec 11 '13 at 17:03
  • I know about those unsovled problems... Do U know how can I roll back to version 11 of the kernel?? I'm not such an expert on the linux OS but I can handle stuff... – OBY Trance Dec 11 '13 at 17:28

I have been having this problem since kernel 3.9.5 and I found a workaround to solve it instead of opening the laptop up or draining the battery which is to shutdown the computer and while the battery LED is still blinking press and hold the power button down until all LEDs turn off (about 5 seconds) this solves the problem until something triggers it again.

I wrote about it here when I first had in September 2013 [link] So it seems to me to be a bug in UEFI that get cleared after a hard power-off like removing the battery or doing the solution I suggested, also a BIOS update fixes it since after the update the BIOS powers off the machine or maybe clears that faulty thing/variable/register!


I have the same setup as you: Ubuntu 13.10 on an Asus N550JV. I had the same issue where the battery was not charging. I followed the method you outlined and the battery was fixed. To summarize:

Step 1: Get the previous kernel

Download the kernel 3.11.0-11 by opening a terminal and typing

sudo apt-get install linux-image-3.11.0-11-lowlatency

(I used the "lowlatency" one because I didn't see the "generic" one in the repository)

Step 2: Start up computer using that kernel

Restart computer and get to the grub menu. If your computer is dual-booted, this menu might come up automatically, otherwise you'll have to get it manually. You can do this by tapping the ESC key as soon as you see the purple screen while booting up.

Select "Advanced Options for Ubuntu", and then "Ubuntu, with Linuxe 3.11.0-11-lowlatency".

Log in normally.

Step 3: Let computer power off

Now unplug the power cable and wait until the computer powers off itself due to low battery. Plug the cord into the computer once it's off, and it should start charging normally.

The problem was fixed for me permanently. I was able to go back to the default kernel (3.11.0-14-generic as of writing this article) and haven't had any issues since.

  • Unfortunately, that didn't do the trick... I've already tried that before with no luck. What I did (then and today as well) was removing the battery and reinserting it again. This issue is very annoying, and I would recommend anyone who plans to purchase this machine and use the same setup to consider purchasing another machine. (Performance wise however, this machine is great!) – OBY Trance Jan 2 '14 at 14:59

Apparently, this is a problem of the hardware itself. I returned one unit for this issue, but I have had it two times on the second unit. Updating the BIOS did not solve it for me, removing the battery did both times.

I have found an alternative solution in this forum. It suggests discharging the battery completely until the machine shuts down from lack of power. I haven't tried it, but will do next time I have the issue.

  • Tnx Roney 4 Ur answer. Strangely it happened today as well.. after kernel update. Damn hardware... – OBY Trance Feb 25 '14 at 21:35

I have an Asus N550JV and I fix this issue by updating the BIOS. Remember if you discharge the battery, you won't be able to update your BIOS anymore. Good luck.

  • Tnx @Tberdy for Ur answering attempt... However that was already been done and was even harmful to my sys since the BIOS is now alerting me about the OS. Very important tip on the battery issue - had to learn it the hard way... :-\ – OBY Trance Feb 26 '14 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.