0

My question is related to what I asked about here: Why is my connection refused when port-forwarding?

So I have a device hooked up to my router and I would like to be able to connect to this device from anywhere where I have an internet connection.

The device is a DVR with security cameras. It is meant to have this functionality.

I already configured my router to allow for the necessary ports at the devices address to be forwarded (at least I think I did everything right - see my other question)

So then when it comes to the configuration of the application, I go to the network settings, and I can select STATIC or DHCP. When I use STATIC, I can select all the IP addresses and such myself, when I go DHCP I can only change the ports, the IP addresses will be chosen by the app.

However, I think there might be something wrong with my app, because the IP addresses don't make sense, at least not if I compare it to the things I see on the configuration page for my router...

It says IP Address: 192.168.001.100 however my router has assigned 192.168.001.253 for this device!

subnet mask 255.255.255.000 seems to be in accordance with what my router says.

But gateway: 192.168.001.001 I think gateway should be the same address as I have to type in to get to my router, shouldn't it? And for me that's ending in 254

Finally it says the same number for DNS 1 which I have a feeling is not correct.

On my router I can see unter Services > Broadband > Status > Internet Details an entry for Primary DNS and Secondary DNS both which are IP addresses, but not so much the standard kind of 192.168.1.1, instead they are somewhat similar to my public IP (and I have a feeling I should not publish them here).

Also I should note that I had to use a Lan-Cable splitter because I ran out of plugs/ports on my router. So the device I am trying to connect is sharing a LAN cable with another device. I am using this kind of splitter

So here are my questions:

  • Why is my application messing up it's IP and such, when on DHCP?

  • Should I set up everything in STATIC mode and enter the information I get from my router?

  • With this method, can I safely use the DNS that I see on my router's configuration page?

  • Also I take it I have to use the private IP inside the network, not my public IP, right?

Thanks for any help, I'm not really savvy with all this network stuff...


EDIT: Starting a bounty

All I want to know is what numbers do I need to plug into the app, so that it'll allow me to connect remotely?

What numbers should I plug in for IP, Subnet Mask, Gateway, DNS1 and DNS2?

8
  • 1
    Seems like you have another DHCP server on your network. Can you tell us more about the splitter you are using? Such a thing is not normally possible, so perhaps it something else.
    – Paul
    Dec 12, 2013 at 1:23
  • Tell me about my DHCP server on my network, because I haven't got a clue about it :D This is the splitter I am using - amazon link It basically allows you to connect 2 devices to the internet using only 1 LAN cable.
    – olli
    Dec 12, 2013 at 1:25
  • 1
    Can you confirm you are using DHCP when you get the gateway of 192.168.1.1 on the DVR? And if you go to http://192.168.1.1 in a browser do you get anything?
    – Paul
    Dec 12, 2013 at 1:48
  • I don't get anything when visiting 192.168.1.1 (it says Chrome cant connect) and how could I confirm I am using DHCP? I could switch to stayic, the DVR will promt me to restart, and then i can switch back to DHCP, again, the DVR will promt me to restart, and then show those incorrect values again. Is that what you are asking?
    – olli
    Dec 12, 2013 at 2:18
  • 1
    If you are going to use portforward with this, then static is the way to go anyway, as you don't want the IP to change. The IP should be whatever you want (outside of the range of the DHCP scope on the router), the DNS should be the router IP and the gateway should be the router IP.
    – Paul
    Dec 12, 2013 at 22:38

1 Answer 1

0
+50

Don't use splitter, that won't work. For splitting ethernet cable you need active device called Switch.

Static IP

If your router has 192.168.1.254, then you may set these:

IP address: 192.168.1.253 (choose address for your DVR, forwarded one)
Netmask:    255.255.255.0
Gateway:    192.168.1.254 (router address)
DNS:        192.168.1.254 

I would recommend to set DHCP pool manually, that way you avoid possible IP collision.

In your routers config, choose Settings -> Lan -> DHCP and select Configure manually

Router Address:     192.168.1.254 (router address)
Subnet Mask:        255.255.255.0 
First DHCP Address: 192.168.1.1   (choose range excluding DVR's IP address)
Last DHCP Address:  192.168.1.252
5
  • Thanks, this makes sense, but still not really doing anything... The status of my device under the routers config now has no IP address assigned to it. In my routers config under Settings -> Lan -> IP address allocation, what should I say for the DVR? public (select WAN IP mapping), private from pool 192.168.1.0 or private fixed: 192.168.1.XXX whereas XXX is between 1 and 252
    – olli
    Mar 2, 2014 at 21:22
  • For DVR, as long as you're using DNAT, you should have IP from your private pool. You can assign IP on your router, based on DVR's HW mac address. If that is not possible, then edit dhcp pool to avoid IP collisions and set fixed private address to DVR (out of dhcp pool).
    – week
    Mar 2, 2014 at 21:41
  • I am sorry but I don't quite understand... So in your first post you recommend to set up the router so it's DHCP protocol will exclude the DVRs specified IP address. From the router I can only assign IPs which are part of the specified range... So should I tell my router to set a static IP for the DVR, from within the DHCP range, or should I do something else?
    – olli
    Mar 6, 2014 at 3:19
  • I cleared the list of devices on my router, and as of right now it wont even recognize the dvr when plugged in - also the little LEDs at the LAN port wont light up... I'VE HAD IT WORKING ONCE BEFORE don't know what the heck is going on now...
    – olli
    Mar 6, 2014 at 3:53
  • If LED's wont light up on both ends (router and DVR), than check if the device itself and router's ports are working.
    – week
    Mar 7, 2014 at 11:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.