In our office all PC are connected in network using workgroup. But sometimes when we connect to a windows 7 shared folder from an Windows xp pc i get error like

\\pc123\myfolder is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.

Access is denied.

But if i restart the Windows 7 PC after getting this error then and retry to connect from windows xp PC then it connects properly. Also from other OS(windows 7 and 8) the pc can be accessed and no error comes anytime, even during the same time when error for windows xp pc came. So this error has no definite sequence to recreate the error. This is not problem with permission as i have full permission for that share. So what may be reason behind this?

  • There is a number of pitfalls concerning sharing folders and devices between Win 7 and Win XP. But: they are well documented. A simple Google search, for instance " Win7 shares WinXP" will get you more info than you´ll ever need. Dec 12 '13 at 12:47

I've had this problem myself, and narrowed it down to "Server" service. Restarting it solves the problem temporarily.

To resolve the problem permanently you need to tweak the Registry of your Windows 7 machine a bit.


  1. Hold Windows key and press R
  2. In RUN dialogue type in regedit and press enter, allow it to run if UAC kicks in
  3. Highlight Computer, and click File, Export - thus backing up your registry
  4. Now locate the following key and change it's value to 1, here is why

    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache
  5. Locate this next key and change it to 3, this is just that "Server" service (or part of it) setting

  6. Restart your computer and see if it happens again.

I should point out that there is a lot of reasons for sharing not to work (firewall, antivirus solutions, incompatible software, faulty hardware...) but you specifically described the problem I resolved like this so many times before.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.