2

I have a Lenova Yoga 2 Pro, and I have Ubuntu 13.10 installed.

I am having some issues setting the power functions. At the moment I can not suspend or hibernate the laptop.

So from Gnome 3.10 I have the option to Log Out, Shutdown & Restart. No option for Suspend / Hibernate.

However I can use these commands to get the right behaviour

sudo pm-suspend
sudo pm-hibernate

So the laptop knows how to do this, it just is not giving me the option and also when I set "Close screen lid" to suspend, well nothing happens. It feels like there is a "connection" not being made.

  • Do you see a battery status? If not, two things come to mind... First, the kernel may be blacklisting the fuel-gauge driver. Second, the BIOS/UEFI may be misreporting the chasis type. You can use dmidecode to see what the BIOS/UEFI is reporting. For an issue report that witnesses both issues, see Bug 1690852, 5 to 20 minutes shutdowns on Cherry Trail machine. The 1690852 was the reverse of your issue - it was a minipc acting like a tablet. You seem to be going the other way - a laptop acting like a desktop. – jww May 10 '19 at 7:20
0

This is a bug and is what you get when you don't stick with the stable version.

Open your command line and put this to edit the config file:

sudo gedit /var/lib/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Copy and paste below lines into the file and save it.

[Re-enable hibernate by default in upower]
Identity=unix-user:*
Action=org.freedesktop.upower.hibernate
ResultActive=yes

[Re-enable hibernate by default in logind]
Identity=unix-user:*
Action=org.freedesktop.login1.hibernate
ResultActive=yes

After reboot, the login screen session menu should have a Hibernate option.

If the first command does not work try this:

sudo gedit /etc/polkit-1/localauthority/50-local.d/com.ubuntu.enable-hibernate.pkla

Here is the question answered: https://askubuntu.com/questions/361734/hibernation-is-still-missing-from-menu-in-13-10-after-enabling-via-polkit-how-t

Try also this:

to enable the hibernate menu option all what you need to do is add “killall indicator-session-service”, without “”, to the stratup applications. and all is done automaticly evey time you start Ubuntu.

| improve this answer | |
  • Thank you - I have done this but still nothing, its really odd! – Charlie Davies Dec 12 '13 at 13:35
  • This is a bug and it might get fixed with future updates. – Devid Dec 12 '13 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.