13

[12/16/2013 - Updates below]
[12/20/2013 - Updates below]

Bear with me, this isn't the normal "limited connection" sort of question, I promise.

When I am at the office and on the LAN, my Win8.1 laptop assures me that my resulting LAN connection is limited:

Win 8.1 saying the connection is limited Network properties saying no Internet Access

Yet I have still have network -- and Internet -- connectivity. I can connect to everything without issue. I get a DHCP address, DNS works, I can surf, ping and work to my heart's desire.

Connectivity evidence

Problem is that some of the Office 2013 stuff balks at being useful. OneNote, for instance, sees that Limited Connectivity status and won't even try to sync to my Notebooks on SkyDrive. Outlook gets a little silly too. Thus, I'd like to fix this limited-but-not-really-limited issue once and for all.

I have tried the following:

  • Swapped cables (no change)
  • Plugged in directly to an office switch (no change)
  • Plugged into LAN side of our firewall (no change)
  • Confirmed the several dozen other machines in the office have no similar issue
  • Plugged other machines into my office jack / switch port -- they were still fine.
  • Updated Ethernet card driver to latest version, to older version, to generic MS version (no change)
  • Assigned static IP and DNS servers instead of DHCP

If I go anywhere else (home, client sites) and plug in my laptop to local LAN I don't get the limited status. So there's something here at the office that my laptop doesn't like.

How do I figure out what that might be?


12/16/2013 - Updates

If I reboot to Safe Mode, the network connection is healthy and shows Internet access. If I then reboot back to Normal mode, it remains healthy for (apparently) the rest of the day or until I use it elsewhere and then return to the office.

I've created an additional local user account, no change. If the connection is limited for me it remains limited for that local user account.


12/16/2013 - Updates

Booting to Safe Mode and then back seems to fix the issue for several days. Thus, the slow down on updates. But it broke again today, so here's follow-up on some comments below.

  • msftncsi.com/ncsi.txt resolves fine.
  • pinging dns.msftncsi.com resolves to 131.107.255.255

However! When checking the Windows 7 Network Awareness link and registry setting, I found that EnableActiveProbing was set to 0, not the default 1 (enabled). I enabled that, disabled/re-enabled the NIC and I have a healthy network again.

So now the mystery is: What is changing that EnableActiveProbing registry key?

  • 2
    You declared your connection to be Public or Home Network or Work Place? Is 10.1 your only gateway in the network? – Gotschi Dec 13 '13 at 17:24
  • Connection is currently "Private". 10.1 is the only gateway on this network, yes. – Chris_K Dec 13 '13 at 17:27
  • 1
    Does it work any differently when Windows is booted in Safe Mode with Networking? – Ƭᴇcʜιᴇ007 Dec 13 '13 at 17:27
  • 1
    @Chris_K Why is your adapter called "(External LAN)"? If you plug it in at home does it also use that "vEthernet" connection? – Rik Dec 16 '13 at 21:44
  • 1
    @Chris_K Yeah, you need to do those suggestions at the moment you have the connectivity problem. So we'll have to wait until you have them again. – Rik Dec 18 '13 at 22:57
4

Nice. You would have thought setting EnableActiveProbing to 0 would have the opposite effect.

This article explains exactly where the key is for. It can disable the probes to msftncsi.com which is to check if you have a good internet connection.

When a Windows machine connects to a network, there are two technologies, Network Location Awareness (NLA) and Network Connection Status Indicator (NCSI); it uses to automatically identify the network it is connecting to and whether or not it has access to the Internet.

It also explains why you have a “limited” connectivity icon (with all the problems that come with it).

Setting this value to 0 will disable active probes. A potential side effect is that, the machines may determine that they don’t have internet connectivity and display a or exclamation “!” on the network icon and “limited” connectivity in the network UI.".

In this case (if you have a good internet connection) setting it back to 1 would get rid of the “limited” connectivity.

There is probably some tool you used, that sets this to 0. When the problem occurs again, check the value, and if it's 0 again there is a tool that's doing it on the background.

Edit:

If you really don't want the check to msftncsi.com i think you need to set multiple options: (source)

  1. Set the following key in the registry (as it was for you):
    HKLM\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing
    set it to: 0

  2. Edit GPO (gpedit.msc for a local machine or gpmc.msc if AD domain wide):
    Computer Configuration > Administrative Templates > System > Internet Communication Management > Turn off Windows Network Connectivity Status Indicator active tests
    set to: ENABLE

  3. Edit a second GPO:
    Computer Configuration > Policies > Administrative Templates > Network Connections > Do Not show the “local access only” network icon”
    set to: ENABLE

But if you can live with the checks to msftncsi.com i would leave them enabled.

For the really paranoid among us there is also the option of running your own NCSI-server
(explained here).


Edit #2:

If there is a utility that's changing the value of EnableActiveProbing to 0 every couple of days (and you can't find it) you could create a EnableActiveProbing.reg on your Desktop and run it once you encounter the problem. (easier then digging through regedit.exe):

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\NlaSvc\Parameters\Internet]
"EnableActiveProbing"=dword:00000001

And... even easier... you could create a batch-file that disables your "Local Area Connection", changes the registry key EnableActiveProbing back to 1 and enables the network connection again...
(i know, i'm lazy):

EnableActiveProbing_and_restart_connection.bat:

netsh interface set interface "Local Area Connection" DISABLE
REG ADD HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet /v EnableActiveProbing /t REG_DWORD /d 1 /f
netsh interface set interface "Local Area Connection" ENABLE

I hope you find the culprit that is changing the key soon...

  • Every few days / week EnableActiveProbing gets set back to 0. I set it to 1, restart the adapter and I'm fine again. Rik turned me on to that key so points awarded. – Chris_K Jan 13 '14 at 16:29
  • @Chris_K You have no idea which program/utility is changing this key? (I would go nuts searching for that one ;) If you can live with changing it back every couple of days its okay too. You might want to make a EnableActiveProbing.reg-file or even a batch-file which does it all for you. I added it to my answer (Edit #2). Good luck finding the culprit that's changing the key. – Rik Jan 13 '14 at 16:55
  • No clue at all which program changes it -- and where it used to get changed almost daily now I can go over a week in between changes. I'll have to use some SysInternals tools to track it down eventually I guess. – Chris_K Jan 20 '14 at 20:00
  • @Rik, Is the automatic msftncsi checks still going on in Windows 8? – Pacerier Oct 3 '14 at 17:22
  • @Chris_K, Uninstall everything and see if that works. If so, install 50% of apps back. If good, install another 25%, if bad, uninstall another 25%, then repeat the half of half of half checks. Even if you got a thousand apps, it would only take ~10 checks (lg1000/lg2) to find the culprit: 1000, 500, 250, 125, 63, 32, 16, 8, 4, 2, 1 – Pacerier Oct 3 '14 at 17:26
0

The latest update changed these default values:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet]
"ActiveDnsProbeContent"="131.107.255.255"
"ActiveDnsProbeContentV6"="fd3e:4f5a:5b81::1"
"ActiveDnsProbeHost"="dns.msftncsi.com"
"ActiveDnsProbeHostV6"="dns.msftncsi.com"
"ActiveWebProbeContent"="Microsoft Connect Test"
"ActiveWebProbeContentV6"="Microsoft Connect Test"
"ActiveWebProbeHost"="www.msftconnecttest.com"
"ActiveWebProbeHostV6"="ipv6.msftconnecttest.com"
"ActiveWebProbePath"="connecttest.txt"
"ActiveWebProbePathV6"="connecttest.txt"
"EnableActiveProbing"=dword:00000001
"PassivePollPeriod"=dword:0000000f
"StaleThreshold"=dword:0000001e
"WebTimeout"=dword:00000023

I customized these with my own resources (Apache web server):

"ActiveWebProbeContent"="My Connect Test"
"ActiveWebProbeContentV6"="My Connect Test"
"ActiveWebProbeHost"="www.mysite.com"
"ActiveWebProbeHostV6"="ipv6.mysite.com"
"ActiveWebProbePath"="mytextfile.txt"
"ActiveWebProbePathV6"="mytextfile.txt"

When testing, it works, as expected -- network status icon shows internet or no-internet when I change the text to match or not-match within the text file hosted on my server for ActiveWebProbeContent.

However, on the negative text, an undesired side effect is happening. A webpage is being auto launched to the URL http://www.msftconnecttest.com/redirect

I searched the registry for msftconnecttest and found none. Where can I update this URL to one of my own? Is there some other magic registry key I can create? Has anyone disected these DLL files in here (maybe the keys are in cleartext somewhere if they exist)?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.