0

I've got a 32gb USB 3.0 thumbdrive and it's been acting up on me as of late. Most of the time I could just unmount and remount it on my Mac's main partition and viola, it'd be working again. However, recently I did a fresh install of Windows, and in order to make space for a larger Windows partition, I moved almost 30 gigs of files from my main partition to the thumbdrive. After using it for a few days I plugged it into a different USB port than usual, and Windows did the whole Scan-and-Recover thing, claiming it moved all the broken files to a folder called "Found". Unfortunately there is no folder called "Found" when I look via Windows (on OS X I see found.000 or something, with a few files that were not put there by myself and clearly taken from somewhere else on the drive, but it's only a few mb at most).

After that happened I didn't use it for anything for a few days, but just earlier I went to pull up a file and realized the folder it was in was... empty. the folder was at least 11 gb in size and now it's 0kb. Absolutely nothing. I checked around on the drive and found that with the exception of one folder, everything that wasn't on the very root of the drive was completely gone. All files that were on root, as well as all folders, are still there. One of these folders has a subfolder in it (supposed to have 3 subfolders) and that single subfolder has all it's original files, as far as I know. Every other folder on the drive is just blank, 0kb.

I freaked out and ran FreeUndelete, but according to that, there's nothing there to recover, nothing that's been deleted. I can't figure out how to check anything other than root on FreeUndelete, though, so in order to test if it's checking just root or the whole drive, I tried to copy-paste a 4byte text document to the root of the drive. I was intending to delete it immediately afterward, then re-run FreeUndelete, but instead I received the message that my drive was, in fact, Write-Protected. No, there is not a switch on the drive to turn that on or off, I have checked several times.

I went to google to find out how to set a drive to something other than read-only but all the results I was getting were people trying to format their drive. Naturally the last thing I want to do is format this drive, as it is basically my backup. I poked around cautiously in CommandPrompt, using the DiskPart -> List Disk -> Select Disk -> Detail Disk method everyone seemed to say to do, and I got this:

Patriot Memory USB Device
Disk ID: 6B81263A
Type   : USB
Status : Online
Path   : 0
Target : 0
LUN ID : 0
Location Path : UNAVAILABLE
Current Read-only State : Yes
Read-only  : No
Boot Disk  : No
Pagefile Disk  : No
Hibernation File Disk  : No
Crashdump Disk  : No
Clustered Disk  : No

  Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
  ----------  ---  -----------  -----  ----------  -------  ---------  --------
  Volume 3     E   32           NTFS   Removable     28 GB  Healthy

So I'm not sure what's up, and I'm not sure why Current Read-only State is 'Yes' when Read-Only is 'No'...

Any help? It's very important that a) I fix this disk and b) I recover all the data from it. I can't stress that enough D:

EDIT: I have tried FreeUndelete and Recuva now, only Recuva has done anything useful, but most of the time it stops halfway through the scan and says it was disconnected, or it only returns a few files our of the thousands that are on there....

0

I do not know why your USB Drive suddenly decided to become Read Only. However one promising method that you can try to fix your USB drive is using USB Mass Production Tools which reprogram the micro-controller inside the USB Drive.

You need to use ChipGenius to find out the correct Mass Production tool for your USB Drive and attempt to reprogram the micro-controller in your USB Drive.

Refer to this question and my answer for more details. You question is similar to this question.

How to format/repair a write-protected USB drive with I/O errors?

  • I don't want to format it, though, which it seems that will do :/ I'll look into it though. – Stryker295 Dec 23 '13 at 0:31
  • You could try Partition Recovery software like Partition Wizard.However, if recuva or undelete did not help, i doubt if partition wizard will help. – bbalegere Dec 23 '13 at 16:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.