I have an ethernet connection to my router. I'm running testing version of Debian (though the problem persisted with the stable too) and I don't have any network manager. My /etc/network/interfaces is thusly configured:

# The loopback network interface
auto lo iface lo inet loopback

# The primary network interface
auto eth0
allow-hotplug eth0
iface eth0 inet static

Every once in awhile the connection just fails; the only pinging that works is to localhost. I've tried using DHCP, which receives offers and generally works well. A temporary fix is to physically unplug the ethernet cable from my computer, wait a few seconds, then plug it back in, a few seconds after doing which the connection works fine again.

  • When your ethernet connection seems to fail, can you ping an IP address? Something like ping -c3, i.e., without a name to be resolved? Dec 15, 2013 at 20:15
  • @MariusMatutiae yes i can ping it fine Dec 17, 2013 at 5:11

2 Answers 2


The answer you gave to my comment, that you can ping when the connection seems to fail, clearly indicates that your connection is up and running without any problem.

Instead, what is failing is your connection to your DNS servers, which clearly are becoming unresponsive. Since you are using a static IP, you may as well set them through your /etc/network/interfaces file. Add this line to the bottom of it:


After a trial run, if nothing untoward happens, you may change these IP addresses to some of your choice, just make sure that they differ from those you are currently using which clearly are not very dependable.

  • gah omg sorry no I had this lapse of intelligence there and I was thinking, when I tested your suggestion earlier, to ping /my own/ router-assigned ip address x.x Yeah, no I've tried pinging to no avail. Dec 18, 2013 at 15:50
  • @NickChandoke Good to know anyway, my answer is useless then. But you can ping your router? Can any other pc, at the same time, ping the router? Or the Internet? Dec 18, 2013 at 15:52
  • Yes - other PCs use the internet fine when mine goes down. Pinging the router does not work. Dec 19, 2013 at 17:14
  • @NickChandoke Next time you experience the problem, could you run this command: sudo ethtool eth0 Dec 19, 2013 at 17:27
  • okay I did so. The output is the same when I have internet as when I don't. Here's a link to the output; it's too long for stack overflow's character limit. link Dec 21, 2013 at 7:19

This smells more like a hardware problem. You may want to check the RJ-45, the cables and the router. You may want to check dmesg | tail to see if the network went down. If it does, is more likely that the system is not at fault (since both testing and stable had the same problem) and more your cable/router.

  • dmesg doesn't show anything of concern when the network goes down, but when I unplug and replug in the cable, i see > forcedeth 0000:00:07.0: eth0: link down and ...link up Dec 17, 2013 at 5:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .