I have an old Intel D945PLRN motherboard, and a NVIDIA 9500 GT connected via DVI cable to a Samsung LCD monitor.

The system freezes sometimes after booting to Windows just recently and when I restart the display goes blank. I tried reconnecting the cables. The CPU, hard drive, fans on the graphics card seem to be running and there are no beeps. Sometimes the display comes back up after I reboot but often it doesnt.

The motherboard does not seem to have integrated graphics that I can switch to. Is my graphics dead, or maybe cables

closed as too broad by Ƭᴇcʜιᴇ007, Jens Erat, mpy, Darth Android, Mark Henderson Dec 17 '13 at 0:31

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 2
    What have you researched/tried to diagnose this? Are you using the most current drivers for the graphics card and monitor? – CharlieRB Dec 16 '13 at 15:12
  • Thanks for the comments. I tested the monitor on a laptop and it's fine. When I power up the lights on motherboard and keyboard, all fans even the graphics card is spinning like normal. Just the display is blank, I dont see the bios POST at all. I dont have another computer that I can test the old graphics card on. – grey Dec 16 '13 at 15:32
  • If you don't have another graphics card to test in this computer, or another computer in which to test the other graphics card, then this question is far too broad / not enough information because it could be anything. – Darth Android Dec 16 '13 at 22:25

If you have a different, working computer around that you're able to disassemble you could try putting your graphics card into it to see if the issue persists.

If the issue occurs on the other computer then it's safe to assume your graphics card is faulty. If the computer operates properly with the graphics card then try swapping out other components until you identify the culprit.

Not the answer you're looking for? Browse other questions tagged or ask your own question.