I am running Windows 8, 64 bit and have SQL Server 2012 installed. I downloaded the client tools, looked in the directory for SQL Server Management Studio, and see it's there. When I try to run SQL Management Studio I receive the error message:

"Cannot find one or more components. Please reinstall application".

This problem just started. I have reinstalled the application and downloaded the service packs. The shortcut key shows the path but it still will not run.

  • 1
    Are you trying to install something? If so what? When do you get the error message? What OS are you running? Please explain in detail exactly what is happening.
    – heavyd
    Dec 16, 2013 at 22:27
  • It's impossible for anyone to answer this question, since you haven't told us what application or OS. Dec 16, 2013 at 22:27

7 Answers 7


Maybe you uninstalled Visual Studio 2010? Try installing the isolated package: Microsoft Visual Studio 2010 Shell (Isolated) Redistributable Package

  • Could you please mind to add more details in you answer? Aug 27, 2014 at 4:48
  • @RenjuChandranchingath, Some features of SQL Server Management Studio requires of MS Visual Studio 2010. Apr 6, 2015 at 21:06
  • This was exaly what was missing - thank you! :) May 18, 2016 at 10:49

I had the same error when trying to open SQL Server Mgt Studio 2012 until I followed this recommended fix by Microsoft:

Posted by Microsoft on 10/25/2011 at 6:01 PM

This happens after installing SQL Server 2012 (Code named "Denali CTP3") or later, running SSMS successfully, then (later) install VS11 Dev Preview, and then run SSMS.

Dev11 Preview improperly recognize SQL Server Denali SSMS as a version 11 application and it updates the current user’s setting in SSMS registry key during the setup. This issue occurs only when Dev11 Preview is installed after the installation of SSMS.

SQL Server 2012 SSMS has a built-in security and resiliency feature for any corrupted configuration in HKCU registry key. The corrupted registry keys can be simply deleted then SSMS automatically reconstructs it with correct values during the next startup procedure.

• Start regedit.exe

• Go to HKEY_CURRENT_USER\Software\Microsoft\SQL Server Management Studio

• Delete 11.0_Config

• Restart ssms.exe

  • 1
    Same goes for 2014, I had 12.0 and 12.0_config in my registry. After several reinstalls, complete cleans, repairs and other shenanigans the web directed me too this 1 minute solution let's me finally start SSMS 2014 again.
    – Madmenyo
    Aug 12, 2015 at 16:17
  • and for Microsoft SQL server 2016, the folder is 14.0_Config. Aug 5, 2017 at 7:00

I had the same issue today. Probably because I had uninstalled VS2012 and may have accidently uninstalled a VS Shell.

Installing the 2014 SSMS Express Edition Fixed my 2012 SSMS


This finally worked for me: http://klevster.com/fix/sql20122014-management-studio-cannot-find-one-or-more-components-please-reinstall-the-application/

I had to uninstall 2010 shell and then repair MSSMS 2014.

From the link above:

Struck an issue with a Windows 2012 Server with VS2012 installed trying to open SQL 2012 Management Studio giving the error:

“Cannot find one or more components. Please reinstall the application”

After having tried a heap of combination of things, installing SQL 2014 Management Studio, uninstalling, reinstalling… Then repairing VS2012, installing SQL 2014 Management Studio again. All to no avail.

What finally got me over the line was to uninstall the Visual Studio 2010 Shell, this was done by downloading the installer from this link: http://www.microsoft.com/en-us/download/details.aspx?id=1366

Once downloaded, run the installer and remove the VS2010 Shell component. Once done, run the SQL 2014 Management Studio installer or do a repair on your existing installation, this will itself reinstall the VS2010 Shell components.

Then bam, it finally opened for me.


I had the same issue. The problem seems to be some kind of access issue. I had logged with my domain account during installation, but disconnected from my domain.

Later I repaired the sql server setup while I am connected to the domain, it worked.


In cleaning off old installs of SQL Server, I uninstalled the VS2010 shell thinking in wouldn't need it for the latest verison I've been using, which is 2012.

Got the same error. Reinstalled the 2010 shell (~1GB in size) and all is healed.


I had the same error on Win2008Server when trying to open SQL Server Mgt Studio 2012 after updating from VS2010 to 2012. I did the registry thing Ray Vega suggested, rebooted, but no cigar. After this I installed the VSIsoShell.exe. Then the SQL Server Mgt Studio 2012 opened OK.

Here's the link to VSIsoShell.exe: http://www.microsoft.com/en-us/download/details.aspx?id=1366

  • I feel this would be better as a comment on the Ray Vega answer, rather than a new answer in itself. Flagged as such.
    – Stese
    Aug 16, 2017 at 15:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.