4

I want to disable laptop (DELL) beeping. So, as you know, I need to go to Device Manager, then choose to show hidden devices and after this I should see "Non-Present Devices" but there is no one.

I have tried to set DEVMGR_SHOW_NONPRESENT_DEVICES=1 option but I have not got any results.

3
  • "So, as you know", nope, don't know exactly what you mean. Did this ever work for you with this notebook model and Windows 8.1? Exactly which device are you expecting to find? – Ƭᴇcʜιᴇ007 Dec 17 '13 at 15:21
  • I want to find "Beep". I've broke my screen, so the laptop is beeping. I find out that I can disable that sound in this way. – Paulius Dec 17 '13 at 15:26
  • If there's damage to the device that causing the beeping (POST failure?) then the beeping is probably out-side the control of the OS. Maybe you should edit your question to be about the actual problem, instead of the solution you're trying (see XY Problem) – Ƭᴇcʜιᴇ007 Dec 17 '13 at 15:34
2

According to this discussion on TechNet and me checking both Windows 8 and Windows 8.1 locally, the 'Non-Plug and Play Drivers' are no longer accessible in Device Manager in 8.x regardless of what you try.

You can always just try to disable the beep driver directly:

enter image description here

change the Start value from 1 to 4, which means disabled.

The corresponding .REG registry file would be:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Beep]
"Start"=dword:00000004

You have to reboot your machine.

I haven't tested this myself, but disabling the beep driver should not break anything else in your system.

1
  • Hi Peter, thanks for this. I've added the exported text for that registry setting as an edit. – Lilienthal Jan 18 '18 at 10:27
1

You need to launch the command line as Administrator by right clicking on it not just from the run prompt.

Start > All Programs > Accessories and right-click Command Prompt, then ‘Run as Administrator’. Type set devmgr_show_nonpresent_devices=1

3
  • It doesn't work. I've tried this. – Paulius Dec 17 '13 at 15:17
  • 1
    Did you click at the top click under View > Show hidden devices? – colealtdelete Dec 17 '13 at 15:20
  • Yes I did. Please, read again my question. J – Paulius Dec 17 '13 at 15:21
0

Other options to view hidden devices in Windows:

1) Registry key: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum 2) Device Cleanup Tool 3) GhostBuster

Reference here:

http://www.sysadmit.com/2015/09/windows-eliminar-dispositivos-ocultos.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.