9

This is a Dell Latitude E6430. There is a setting in the bios to control this behavior and I have DISABLED it but it still happens. I am also running the latest bios.

When I plug in a network cable the wifi adapter becomes disabled. I need it to stay enabled. What else could be making this happen?

EDIT: The reason I need to do this is because with NETSH WLAN commands you can create a wifi hotspot by sharing the internet connection on the wired adapter and broadcasting a ssid on the virtual wifi nic. I do this all the time but it's not working on this laptop. I'm wondering if it's a network security thing where I am. I'm going to try from my hotel tonight and report back.

1
  • Whats the make and model of the network adaptors? Drivers may be doing this and/or some kind of Dell Utility. I don't believe this a default windows behavior.
    – MDT Guy
    Dec 17, 2013 at 17:27

6 Answers 6

4

In my case the problem was a Windows service called "Wireless_AutoSwitch." I have no idea how or why it was installed but disabling it fixed the problem.

2
  • Can't imagine that Wireless_AutoSwitch is standard software on a Dell. Especially with the fact that your Dell has that capability of itself in its BIOS. But good its fixed now.
    – Rik
    Dec 18, 2013 at 18:59
  • The Wireless Auto-switch service was responsible in my case as well. I use a software called Dispatch that allows me to connect to two different networks simultaneously. After I updated my Dell laptop in July suddenly I found this behavior occurring. By stopping the service I was able to enable" the wireless adapter as well as connect to a LAN. Good Solution.
    – user359797
    Aug 20, 2014 at 14:51
2

What kind of adapter does the Dell have?

For instance, here you can see that the "Intel® PROSet/Wireless" has software which can disable the WiFi when a LAN cable is connected. You need to disable that option there too.

So look in the system-tray for such software and look for that option.
(Or tell us the make/model of the WiFi adapter and we can look for it too :)


enter image description here


Edit #1: (more options to try)
According to this your "Intel(R) Centrino(R) Advanced-N 6205" can come with the "Intel® PROSet/Wireless Software". But if you can't find it in the system-tray or "Installed software" i guess it's not at fault. I doubt there is a setting in the driver for the LAN-adapter but it never hurts to check. Also check the settings of the WiFi-adapter for such option. Also remove the check here of your WiFi adapter. It might be that Windows shuts it down when a cable is detected.

enter image description here

And here is another option to check. You need to set the "Power Saving Mode" of your WiFi adapter (in Advanced Power options) to "Maximum Performance".

enter image description here


Edit #2:
I guess you mean by you disabled it in the BIOS you did the reverse of this:

  • Go to BIOS by press F12 during reboot.
  • Power Mgt ==> wireless radio control
  • UN-check the "Control WLAN RADIO & Control WWAN RADIO"
  • Reboot the laptop.
5
  • Interesting. The wifi nic is "Intel(R) Centrino(R) Advanced-N 6205." I don't have any Intel management software installed so I'm not sure this would be causing the issue. Thoughts?
    – Jimmy D
    Dec 18, 2013 at 14:37
  • According to this your Centrino Adc. 6205 can come with the "Intel® PROSet/Wireless Software". But if you can't find it in the system-tray or "Installed software" i guess it's not at fault. I doubt there is a setting in the driver for the LAN-adapter but it never hurts to check. Also check the settings of the WiFi-adapter. Also remove the check here of your WiFi adapter. It might be that Windows shuts it down when a cable is detected.
    – Rik
    Dec 18, 2013 at 14:59
  • And here is another option to check. You need to set the "Power Saving Mode" of your WiFi adapter (in Advanced Power options) to "Maximum Performance".
    – Rik
    Dec 18, 2013 at 15:02
  • Added an Edit #2: I guess you mean by you disabled it in the BIOS you did the reverse of this. You did NOT check that box.
    – Rik
    Dec 18, 2013 at 15:14
  • See my posted answer.
    – Jimmy D
    Dec 18, 2013 at 18:34
2

For me, I had the same issue whereby when I plugged a network cable in, my wireless adapter was disabled automatically. I found that this http://www.wirelessautoswitch.com/ was running as a service "Wireless Autoswitch" on my machine. This is a paid for application that had presumably been installed by the network administrators of my work network in order to prevent intentional or accidental of bridging between networks (corporate and guest, or VPN and home for example). After stopping the service, it was possible to have the wireless network card enabled whilst a cable was connected to the wired NIC.

0

I think this is caused by Windows' order of adapters. You can see in the screenshot below what I mean:

enter image description here

You can get here by opening Control Panel, Network and Internet, Network and Sharing Center, Change Adapter Settings (left side) and then press ALT once and you'll see a menu appear. Go to Advanced -> Advanced Settings. Now you will have the window open shown above in the screenshot. The idea is to put your wireless adapter as high as possible. Press OK to save. You might have to restart your PC in order to let the setting take effect.

0

What seem to have worked for me is the metric setting. What it does is that if two internet connections are available, the data will flow through the one with lower value. This presumably also makes the connection persist, if it has the lower value, when the other one is then connected.

Wi-Fi : metric = 10 // this one will be preferred and won't disconnect
Yoga Tablet Tethering : metric = 20

enter image description here

-2

I believe this a safety reason as both your wifi and Ethernet are on the same network and it would cause a conflict if both would work at the same time. Just go to your network and sharing center --> Change adapter settings, disable your wired connection and enable your WIFi.

Or just make sure the wired connection is on a different network. (It can be used for internet sharing for example)

2
  • 4
    Negative. You can have many adapters on the same network and they can all have their own IP address.
    – Jimmy D
    Dec 17, 2013 at 21:03
  • You can even have multiple IP addresses on the same adapter. Sep 18, 2018 at 14:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .