0

When I type an address that doesn't exist in web-browser "aidjaoihahg" and press enter I come to my Internet Providers IIS server. It is an IIS 8 default website with IIS8 logo etc. "aidjaoihahg.universal.se" Say WHAT?

looking at "ping aidjaoihahg" shows ip: xx.xx.xx.xx and "tracert xx.xx.xx.xx" shows up with a server http://dilbert.uvtc.net The uvtc.net is a shortform of my internet provider Universal Telecom.

I have checked ipconfig /all and computer, picks up this entries:

    DNS Suffix Search List. . . . . . : universal.se
    Connection-specific DNS Suffix  . : universal.se

From reading, these entries are supposed to apply to unqualified names, but Windows DNS is applying them to all DNS lookups and triggering extra DNS lookups on bogus addresses. I think.

I am not setting that DNS suffix and search list anywhere. And would think it is picked up from my internet provider? I have tried to pull out the DNS Suffix Search List from group policies. Not sure this is applied correctly.

Local Group Policy Editor->Computer->Administration Templates->Network->DNS Client->DNS Suffix search list->Disabled. 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters show SearchList empty

How can I make the computer from applying the "*.universal.se" to all bogus DNS lookups?

On the Network Connections "Ethernet adapter vEthernet" I have the default settings on TCP/IP DNS tab:

-Append primary and connection specific DNS suffixes [checked]
-Append parent suffixes of the primary DNS suffix [unchecked]
-DNS suffix for this connection: [empty]
-Register this connection's addesses in DNS [unchecked]
-Use this connection's DNS suffix in DNS registration [unchecked]

ipconfig /all output:

C:\Windows\system32>ipconfig /all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : myComputer
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : universal.se

Ethernet adapter vEthernet (Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Control
ler Virtual Switch):

   Connection-specific DNS Suffix  . : universal.se
   Description . . . . . . . . . . . : Hyper-V Virtual Ethernet Adapter #2
   Physical Address. . . . . . . . . : 20-CF-30-39-XX-XX
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 192.168.0.199(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : den 17 december 2013 17:24:56
   Lease Expires . . . . . . . . . . : den 18 december 2013 17:24:55
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter Teredo Tunneling Pseudo-Interface:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : XXXX:X:XXXX:6ab8:487:1242:ac2e:XXXX(Prefe
rred)
   Link-local IPv6 Address . . . . . : XXXX::487:XXXX:ac2e:XXXX%5(Preferred)
   Default Gateway . . . . . . . . . : ::
   DHCPv6 IAID . . . . . . . . . . . : 83886080
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-1A-04-XX-50-20-CF-30-39-XX-XX

   NetBIOS over Tcpip. . . . . . . . : Disabled

Tunnel adapter isatap.universal.se:

   Connection-specific DNS Suffix  . : universal.se
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-XX-00-XX-00-00-00-XX
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : XXXX::5efe:192.168.0.199%11(Preferred)
   Default Gateway . . . . . . . . . :
   DHCPv6 IAID . . . . . . . . . . . : 184549376
   DHCPv6 Client DUID. . . . . . . . : 00-XX-00-01-XX-04-XX-50-20-CF-XX-39-3A-8B

   DNS Servers . . . . . . . . . . . : 192.168.0.1
   NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Windows\system32>

Note I am using Hyper-V server on this computer so my "Ethernet adapter vEthernet" is where I set DNS settings.

Hyper-V Virtual Ethernet Adapter is using "Ethernet" connection "Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller", the Marvell one only have one Hyper-V Extensible Virtual Switch item on properties so I cant set "DNS on TCP/IPv4" there.

  • 2
    You say you know it's going to apply those DNs suffixes to unqualified hosts, yet you start by saying your surprised that it's adding it to an unqualified host name you put in. Do you understand what a "qualified" host name is? Why not just take that domain out of your DNS Suffix Search List? Why is it in your settings at all? – Ƭᴇcʜιᴇ007 Dec 17 '13 at 16:57
  • 1
    if you have truely never configured a search entry for Universal.se, then you may be the victim of ISP NX-squatting, but that doesn't explain why it appears in your DNS search list. for your nic, under IP settings, click the advanced button, and remove any settings under the DNS tab. – Frank Thomas Dec 17 '13 at 17:17
  • 1
    under Computer -> Properties under Computer Name, Domain and Workgroup settings, what do you see under 'Full Name'? – Frank Thomas Dec 17 '13 at 17:36
  • 1
    Is 192.168.0.1 another computer or a router? It is acting as your DHCP server and could be passing universal.se to you. – sgmoore Dec 17 '13 at 18:00
  • 2
    if that is the case, then it is likely your ISP intercepting any NX responses and directing you to their page. – Frank Thomas Dec 17 '13 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.