Powershell is opening with extremely small font (about 5 pts). When I go to Defaults > Font, the setting is a reasonable 8 x 12 pixels but that is not what is showing on the screen. I try changing some of these settings, but there is no change. When it first opens it appears for a split second at the expected size and then shrinks into the top left corner. This appears to be a bug.

I am aware of this question regarding certain fonts requiring certain font sizes. Recommendations in answers to that question have been attempted with no success. This is a different problem.

OS: Windows 8.1 Powershell opened as Administrator.

  • What OS? Are you admin on the machine? – user94184 Dec 18 '13 at 0:53
  • @ShawnMelton Have updated question. Cheers. – dave walker Dec 18 '13 at 1:25
  • 1
    This question is not a duplicate of the linked question. The linked question has to do specifically with a Lucida Console font issue. – Rynant Dec 18 '13 at 17:47
  • 1
    I experienced the same issue in Windows 8.1. The only fix that worked for me was to use Consolas instead. If I used Lucida my settings were not saved. – Ben Foster Dec 23 '13 at 10:43
  • 1
    This has been logged with Microsoft Connect -connect.microsoft.com/PowerShell/feedback/details/806286/… – Ben Foster Dec 23 '13 at 11:02

Try changing the font from 'Properties > Font'.

You are probably opening PowerShell from a shortcut. Console shortcuts can have their properties set separately from the defaults. You can also right-click a shortcut, click properties, and change the font from there.

  • Thanks @Rynant. That solved my problem. I deleted the shortcut from the start menu folder and replaced it with a newly created version. That fixed the problem. – dave walker Dec 19 '13 at 22:17

If you use the default shortcut at C:\ProgramData\Microsoft\Windows\Start Menu\Programs\System Tools you will have some permission problems.

Right click your shortcut. Run as an Administrator go to properties, change Font size and layout but CHOOSE Raster Fonts. (Console will not work).

Close program and open as usual. Saving properties with Console Font just reverts to open the powershell at desired Font size and inmediatelly changes to tiny fonts again.

If you create your own shortcut anywhere else, everything will work just fine.

  • This is the correct answer. The accepted answer will give the same problem over and over again. The comment about deleting the shortcut and creating a new one is what actually fixed the problem. – kjbartel Jul 6 '15 at 13:35
  • 1
    Console will not work - That's the key. Thanks Bart – Vincent Mar 25 '17 at 14:53
  • (Win 8.1) Shortcut properties has a bug. Let's say you change Run from Normal window to Minimized, and then the font from 12 to 14 pt. Changing the shortcut prompts for administrator credentials, and the Run setting changes, but the font size setting is thrown away.(FAKE BLANK LINE)Running PowerShell as administrator and making the change from the system menu does however update the shortcut. Strange. – Daniel Beardsmore May 26 '17 at 10:43
  • This should be the answer; and Console font worked for me. – 7kemZmani Feb 20 '19 at 8:16

I got it to work by

  • Launch PowerShell
  • right-click on the Taskbar icon
  • right-click again on Windows PowerShell
  • choose Properties

and edit it from there. As per @bart-calixto's answer, I still had to choose a raster font.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.