1

I have Windows XP Professional Version 2002 SP 3 English version
I have installed the required input methods in Regional and Language Settings and as far as I know all the other options provided there regarding multiple languages. I can also type in Korean characters (as well as other Asian characters) in notepad, word, etc and view those characters in the browser as well
However, when I try to view C++ code in Visual Studio (that I copied in from another computer), or open the cpp file in notepad or notepad++, the Korean characters look like this:
// Ç¥ÁØ »ý¼ºÀÚÀÔ´Ï´Ù.
when they should be looking like this:
// 표준 생성자입니다.
I got the above Korean characters by opening the same cpp file in Word, using the following options when word starts up:
enter image description here
which shows that entire information about the actual characters is still present inside the cpp file, but for some reason the text editors are not able to display them properly.

Even worse is, I am having to work in a Korean version of VS2003 installed in this computer, and while most of the menu items display properly in Korean, many of them just appear as ????????????? (i.e., as strings of question marks). This includes error messages in dialogue boxes as well as some text in places like the resources explorer.

What should I install or update in my computer so that all the English as well as Asian characters show up properly?

  • Try converting the C++ source code files to Unicode for use in Visual Studio. See C++ source in unicode. – martineau Dec 18 '13 at 8:20
  • Thanks, but the problem is not just with the C++ source code. The computer has problems displaying any text files with Asian characters, although the complete data representing those characters seem to be present within the file itself. I need to solve this problem for all use cases on this computer. Also, when I run the Korean version of Visual Studio 2003, some characters in the user interface appear as ? marks. I need to solve that as well – user13267 Dec 18 '13 at 8:32
1

Windows XP has the option of installing the additional East Asia (Chinese, Japanese, Korean) language packets in Regional Preferences > Idioms. More information here.

You need to have the original installation disk however. Besides the appropriate fonts, it also installs a sort of IME.

As MSalters states, keyboard layouts do not have relation to what characters you are able to see on Windows.

  • I have already installed everything related to languages in the Regional and Language settings. I'll check again once I get the chance, but I don't think that is the problem – user13267 Dec 18 '13 at 12:55
0

Input methods are unrelated to output. You clearly have an output problem.

The next issue is that you need "Fonts". A font describes how to draw characters. For instance, it probably includes a shape for character 64 that looks like A and another shaped numbered 65 that looks like B. But many fonts do not include a shape.

You'd need at least a fixed-width and a variable-width font for Korean. Windows will try some font substitutions, but fixed-width and variable-width fonts can't be substituted for each other. Seeing Korean in some but not all places suggests a font is missing. In particular, Visual Studio uses a fixed-width font for code.

As for saving .cpp files, just use UTF-8 with BOM. I think even Notepad understands that.

  • The cpp files were saved on a computer with Korean Windows, and open up normally there. On another computer with English Windows 7 but appropriate language packs installed, it shows up normally. The problem is only seen in this particular Windows XP computer. – user13267 Dec 18 '13 at 12:53
  • Again, if the problem of the characters not displaying in Visual Studio is due to fonts, which fonts should I install to make them appear correctly? – user13267 Dec 18 '13 at 12:54
0

I've had problems with Asian games that required changing the locale to the proper country. There was a program called App Locale that occasionally solved the issue at the app level, but for system wide changes (like garbage text in ID3 tags) I think you'll need to change to locale to Korea.

You can then save the files in a more common format.

You can also try running your text editor in App Locale.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.