6

When I look at files in the Windows-8.1 file explorer, I can right-click a file and select "Open With" to choose a program that allows me to open that file. For instance: when I select a PDF file, I can choose Adobe Acrobat, Adobe Reader, some MS PDF viewer and Firefox.

I do no want to change the default program (which is Acrobat in my case), but I want to add another program I've written myself and that allows me to inspect the PDF syntax.

Currently, I need to use "Choose default program...", uncheck "Use this app for all .pdf file" and than select that specific program in "More options." That involves quite some clicks and I would like the program of my choice to show up as the second or third item in the list that is provided when I click on "Open with..."

I've Googled around, but all answers refer to something called "Group Policy Management Console" which is apparently something that is available on Windows Server and that allows administrators to configure policies for multiple users. I'm a single user on a single PC; I don't think I have (access to) this "Group Policy Management Console" (I can't find it).

Is there another way to expand the list of apps when I click on "Open with..."?

2 Answers 2

8

The answer is ridiculously simple - just make sure your application has disk:\path_to\your_app.exe.ApplicationCompany string with any meaning e.g. Soopa-troopa soft in [HKEY_CLASSES_ROOT\Local Settings\Software\Microsoft\Windows\Shell\MuiCache].

After creating this registry key open desired file with your application and it will appear in Open with list.

3
  • As I had to install a new computer, I forgot how to add a exe to "Open with...", so I looked up the initial answer I accepted (and that works perfectly) and discovered this second answer. I tried it, and it works. Although I like the initial answer, this answer is a more accurate answer to the actual question. Aug 21, 2014 at 14:54
  • As we all probably know (see support.microsoft.com/help/256986), "HKCR" = "HKLM\Software\Classes" + "HKCU\Software\Classes". In a case of collision, HKCU has a higher priority. But when saving some key to HKCR, if key already exists in HKCU, it is created in HKCU, otherwise it is created in HKLM. But in your case we DON'T want to create this key in HKLM, because it don't have "\Shell\MuiCache" subpath. This subpath exists only in HLCU. So the correct path to save this key will be: "HKEY_CURRENT_USER\Software\Classes\Local Settings\Software\Microsoft\Windows\Shell\MuiCache".
    – SLA80
    Sep 9, 2020 at 4:43
  • What if we are dealing with Microsoft Store apps? Those do not have a disk path like that Apr 22, 2021 at 16:58
2

There is a program mentioned in another Question. Maybe it will do the trick. It's called 'Default Programs Editor'. The changelog says its old though. Last update from 2010. There is also an answers which dives deep into the topic.

3
  • Aha, I'm working on my old Windows 7 machine now, but I'll try it on Windows 8.1 in the weekend and accept the answer if it works (I already upvoted it). Dec 19, 2013 at 16:11
  • The suggestion you made didn't solve my problem, in the sense that I added my home-made .exe to the "Open with..." list without any effect. I can change the list, but apparently only with a set of "registered" apps (and my .exe isn't registered). However, your suggestion did help me out as I was able to add my .exe to the Context menu. I now have the option to choose "Inspect PDF" in which case my .exe is executed. That really helps me out. Dec 19, 2013 at 17:30
  • I think an application in windows 8 has to be registered for the specific mime type to be used for entries in the "open with" list. I found some other solutions. I post them later, no time right now. I'm glad I could help for now.
    – sthag
    Dec 19, 2013 at 18:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.