the F12 Developer Tools windows is empty on my machine.

Missing dev tools

I've tried the following solutions, but nothing worked




My IE version

  • What is your Windows version, and does this happen if you logon as another user or run in noaddons mode?
    – harrymc
    Jan 21, 2014 at 19:45
  • Windows 7 : Microsoft Windows [Version 6.1.7601] If I log on as another user I get the same error Also in no addons mode, the same thing
    – q99
    Jan 22, 2014 at 6:50
  • What happens if you reset your browser settings? Tools > Internet Options > Advanced > Reset Internet Explorer settings [reset].
    – Steve
    Jan 22, 2014 at 8:26
  • i did a reset and a reboot, still nothing...
    – q99
    Jan 22, 2014 at 8:38
  • Is your machine part of a domain? Developer tools can be disabled by group policy
    – squareborg
    Sep 28, 2015 at 15:48

7 Answers 7


It looks like the 'shell' part of F12 is loading, but the tools themselves aren't loading. Is there anything on your system that would impact loading a browser control from resources in a dll (specifically the F12Resources.dll). For example do you have any virus scanners or settings that block the res:// protocol? Do you see anything in the event log?

  • I've got system center endpoint protection, but if I disable Real-time protection, still nothing shows up in IE
    – q99
    Jan 21, 2014 at 19:27
  • 1
    Strange, very strange. Not sure what to do. To look at the issue further I think we'd either need to remote debug the issue or get a dump. Would you be interested in working with me on trying to get either of those? If so you can email me at andy_dot_sterland_at_microsoft_dot_com and we can work out next steps. Jan 22, 2014 at 19:00
  • 1
    I'll write you an email in a few minutes.
    – q99
    Jan 22, 2014 at 20:33

Issue is due to the Update Versions: RTM (KB2841134).

Refer the issue on Microsoft Feedback

Best way to fix is to update the Internet Explorer 11 to the Latest Knowledge Base (KB) update

However, you can update from the below location

Control Panel\System and Security\Windows Update

Install required Important Updates and Optional Updates


According to your picture, that's not the latest version of IE11 for Windows 7.

Update to the latest version and if that doesn't help, uninstall IE11 and reinstall it (using the latest version).

You may also want to run a sfc /scannow if you haven't already, to ensure system files are in place and not corrupted.

  • 1
    I uninstalled the IE11 update, the IE went down to v.10, the developer console was there, then I downloaded IE11, ran the F12 DevTools but it is missing again :(
    – q99
    Dec 18, 2013 at 17:02

I don't know what the problem is, but I just remark that every new version of IE destroys development tools in some way, later fixed via Windows Update.

If no one else comes up with a solution to the problem, and if you do not want to wait for Microsoft for a fix, I can offer as a temporary workaround using Firebug Lite. The Lite version is pure JavaScript, but the non-Lite version is only available as an extension of Firefox.

See this video for installing it : Installing Firebug Lite on Internet Explorer.

  • I use Chrome Develop tools for this, but I needed to debug an script inside IE(cause this magic browser has always some kind of problems), I ended up using an virtual machine where the develop tools work, now I'm just curious why it won't work on my machine
    – q99
    Jan 22, 2014 at 11:40
  • 1
    Firebug Lite works in IE. You could try seeing what happens on a vanilla Windows 7 (even in a VM), as this could be some setting on your computer.
    – harrymc
    Jan 22, 2014 at 13:48

Click on

System Configuration -> Administrative Templates -> Windows Components -> Internet Explorer -> Toolbars

A new window will open with the Toolbar options.
Open "Turn off developer options" and in the new window choose "DISABLED".


this happened to me in windows 8 on more than one occasion. I was at the end of my tether until I noticed that the IE icon on my toolbar was indicating that there were multiple windows. I opened it up and it was showing the browser window and inspector window. I switched to the inspector window from the toolbar IE icon and it was showing up fine on my desktop, so I clicked the button that controls if the inspector shows up in the browser window or on its own. When you detach it and use it as it's own window and it works much better.

Not sure if the same will be true for windows 7, but if anyone has this problem for windows 8, this solution seems to work :)


This happened to me and the answer was that my machine (win8.1) wasn't being patched per the group policy since the rest of the company's on win7 and the patches are controlled.

When I forced the update-- there's a link on the windows update dialog box that says "Check online for updates from Microsoft Update". I got a gig a of stuff to dl and installed it and we were fine after that.

NOTHING until then- wiping bits of the registry, uninstall ie11, reinstall, etc, worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.