1

Is it possible to increase the timeout time for attempting to connect to a computer using Windows Remote Desktop client?

My Windows Server 2012 computer was running very slow yesterday, and then became unresponsive. This morning, I was able to get a single ping reply from it, which leads me to assume it's on and functioning, just very very slowly. As it stands, RDC just fails to connect, but I hypothesize if I can increase the timeout time, it might be able to connect so I can reboot the machine. Is it possible to do this? Is there any way to increase the Remote Desktop Connection client's connection timeout/number of attempts?

5
  • I would suspect that increasing the timeout to connect (if you can find a way to do it) is not going to help when following packets are coming too slow for the connection to hold. Dec 18, 2013 at 16:56
  • I don't have physical access to it. It's a server I left in my apartment, but since I'm home for the holidays I can't get to it, and I was an idiot and didn't enable any other ways to access it besides remote desktop. Dec 18, 2013 at 16:58
  • Crappy. For future reference: Remotely turning on or rebooting a frozen computer :) Dec 18, 2013 at 17:20
  • Try using an alternate RDP client like freerdp? My guess is that it won't help though.
    – Zoredache
    Dec 18, 2013 at 17:51
  • Unfortunately, it looks like freerdp is made to be built on Linux/Mac. I could try to get a PC ready to build it for Windows, but I don't feel like going through the trouble right now. Though to maybe prove my point, further attempts to connect have gotten beyond "Initializing remote connection" all the way to the "securing remote connection" stage. That initializing part seems to be the problem area that stops if it takes too long; latter stages will go on for a while before they quit. Dec 18, 2013 at 20:06

2 Answers 2

2

Click the blank black screen once every 5 seconds until the user login appears. From personal experience, I find that clicking the screen like this keeps the session alive.

2
  • 1
    Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Jun 7, 2023 at 10:51
  • So this actually seems to work. Our system networks were slow validating login credentials so RDC connections were timing out after a minute or so. I tried over and over again then tried this method and it worked after a couple minutes. I did intermix clicking in the screen along with pressing ctrl-alt-end. That is end instead of del to bring up the task manager on the remote computer. Not sure if it was need but that's what I did.
    – joecap5
    Jun 20, 2023 at 20:41
1

This may be a bit late, but maybe it still helps someone. We are using a wrapper for the native Remote Desktop Client called RDP+. We had a similar issue where a remote system over an IPSec VPN took a while to respond and this fixed the issue. It has some nice additional features, including a timeout parameter, which tries the connection for x seconds:

/t:20

This will try for 20 seconds to establish a connection.

License:

Remote Desktop Plus is FREE to use for home, personal or corporate use.

For more details, please check their website.

1
  • Wow! Thank you for suggesting this.
    – Sam Sirry
    Sep 21, 2023 at 5:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .