48

This question already has an answer here:

I am not sure but when I start my Command Prompt in Administrator mode, I can't switch to a mapped drive. I can do so if I am not in Administrator mode.

Am I missing something simple?

marked as duplicate by Pimp Juice IT, Overmind, Ramhound, fixer1234, G-Man Jul 10 '17 at 3:49

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What are the permissions on the network mapped drives? – Ramhound Dec 18 '13 at 19:56
  • 3
    That's normal. Map them again in that command prompt. net use driveLetter: \\YourUNChere – Mark Allen Dec 18 '13 at 20:00
52

When you start a command prompt "As Administrator" it's running in a different user context than when you don't.

Since mapped drives are user-centric, that Admin user context will not have the (same) drives, and you'll have to map them for that user context once the command window is open as Adminsitrator, e.g. by running net use <letter>: \\<server>\<share>. An example:

net use Z: \\SuperServer\SuperShare

Also, you can enable the EnableLinkedConnections flag in the registry to cause the session token to be shared:

To work around this problem, configure the EnableLinkedConnections registry value. This value enables Windows Vista and Windows 7 to share network connections between the filtered access token and the full administrator access token for a member of the Administrators group.

To do this, set the HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System\EnableLinkedConnections DWORD flag to 1, and then reboot your machine.

For more info on that from Microsoft, see: Some Programs Cannot Access Network Locations When UAC Is Enabled

  • 3
    This workaround has never worked for me and I'm not sure why. Tried on Windows 7, 8 and 8.1. Trying to access Parallels mapped network drives (\\psf*) from within a Windows VM. – Jason Duffett Jan 13 '14 at 15:37
  • 2
    @JasonDuffett same scenario here. Got it to work with: net use Z: \\psf\Home – Giorgio Bozio Mar 17 '15 at 10:15
  • The EnableLinkedConnections registry flag does not work for me, on Windows 10. net use in an administrator console works. – Tor Klingberg Aug 31 '16 at 13:58
  • Not working for me either on Windows 7 x64 - net use ... works fine – Angelos Pikoulas Apr 20 '17 at 20:34
15

This makes me think about an old Windows Vista reported issue.

Can you try:

  1. Open RegEdit
  2. Go to HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\System
  3. Create a DWORD value named EnableLinkedConnections and set it to 1
  4. Reboot the computer
  5. Test again
  • Cannot find HKLM in Windows 10 registry, where is it? Ahh I see HKEY_LOCAL_MACHINE. – Owl Aug 28 '18 at 14:47
  • 1
    Yes that didn't work for me in Wondows 10. – Owl Aug 28 '18 at 14:52
  • worked for me, thanks! – user2673238 Jun 12 at 11:29
5

One other work-around that took me ages to find is to run net use from a scheduled task as the NT AUTHORITY\SYSTEM account. Apparently drives mapped under this account show up for all users and all elevation levels.

I've tested this and it works even on NFS shares (which can be a bit finicky). Just create a scheduled task set to run at system startup, and specify the following command:

net use //server/share Z: /persistent:no

It might possibly work to run it just once with /persistent:yes, but I haven't tried that. Granted, "just map it again" works too, but that drive still won't be visible to scheduled tasks running in different contexts. The downside is that all real users see it too, so not so good for multiuser setups.

Not the answer you're looking for? Browse other questions tagged or ask your own question.