5

I have set up Google's Cloud Print on my local PC. I added a classic printer, an HP Deskjet 845c.

I then used Cloud Print from Chrome to print a test page. However, it just queues the job and does not actually print the page. I then used my tablet to Could Print; once again it queued the job without printing.

So I now have 2 jobs waiting in the queue of my printer when I check, but the jobs are not printing.

What can I do to troubleshoot this?

  • Just to be sure...the cloud print connector is running when this happens? – Carl B Dec 27 '13 at 15:03
  • Yes, I assume so...Chrome is running – Stevie G Jan 4 '14 at 19:11
  • YMMV, but here's what worked for me: access chrome://devices from the device you just order to print (assuming it is a desktop computer or a laptop). Then click on 'manage' next to the printer you want to print with. This should unstuck the queued jobs. – thiagowfx Mar 14 '17 at 6:12
1

I had a similar issue and solved it with Google's support advice. In my case, there were two printers with the same name and that caused a problem. Also, you do not note what OS you are using, but there is a requirement for Windows XP to have sp 3. I am also using Google Chrome as suggested by Google.

Their suggestions:

Make sure your Google Cloud Print connector is running on a computer that is turned on and using the latest version of Google Chrome.

Make sure your printer is on and connected to the computer running the Google Cloud Print connector.

Make sure you're printing to the correct printer. Sometimes, there may be duplicate printers shown.

In Google Chrome, select Settings and click the Show advanced settings link. In the "Google Cloud Print" section, click Sign out of Google Cloud Print. Visit the Google Cloud Print management page and click on Printers. Delete any duplicate printers (printers with the exact same name) and then sign in to Google Cloud Print again.

Source

  • Os on client is Android Latest, OS on Print Server is Windows 8 64 bit – Stevie G Jan 4 '14 at 19:11

protected by Community Jan 20 '15 at 12:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.