On Windows 8.1, I tried to install the latest Synaptics Touchpad Driver v17.0.19 and it failed for some unknown reasons. Turns out it's problem with Synaptics, not Windows. Synaptics did not "Sign" the files inside the installation properly, and so Windows doesn't allow the installation. See below for lots of solutions.

  • The first step is we need the installation log file that provides us more information other then simply "it failed". – Ramhound Dec 19 '13 at 15:38
  • Locate Synaptics.log – Ramhound Dec 19 '13 at 16:00
up vote 12 down vote accepted

Thanks to Fabian for informing me of the risky nature of Dev-Host, prompting this much-needed update.

I experienced the same issue, and thought I'd try reinstalling old drivers to see if that helped.

Solution/permanent workaround

A more permanent solution taken from the answer posted by Anonymous, reformatted with pictures shamelessly taken from this article on HowToGeek.

The short version solution of this is: disable driver signature enforcement and then install the latest Synaptics driver.

Disabling driver signature enforcement

  1. Press Win+I, or open up the Windows Charms bar from your right upper/lower corner and select "Settings".

  2. Select "Change PC Settings" from the Settings-part of the charms menu.

    Selecting "Change PC Settings"

  3. In the Settings-app, select "Update & recovery".

    Selecting "Update & Recovery" from the Settings-app

  4. Then, choose "Recovery" from the same left-side menu.

    Selecting the sub-menu "Recovery"

  5. You'll get the following display, where you'll need to restart your computer to continue, which will happen when you select "Restart now".

    Pressing "Restart now" before entering the startup repair menu

  6. Now, once restarted, you'll need to select "Troubleshoot" as the option on the startup menu.

    Startup menu, showing "Troubleshoot" as an option

  7. Head into the "Advanced options".

    Select "Advanced options"

  8. Then to the core of what we're looking for: "Startup Settings"!

    Selecting "Startup Settings"

  9. We'll have to do another restart, as we'll be modifying options that are applied at boot.

    Time for another restart

  10. At last, now you'll have to press F7 to disable driver signature enforcement for this boot.

    Screen showing the boot-up options

  11. When your computers has booted up, you'll need to install the Synaptics touchpad driver, and it should complete without issue.

  12. Once installed, it's highly recommended that you restart your computer one last time.

In the event that it doesn't seem like the touchpad driver is in use, you'll need to manually change the driver for your touchpad device. Here's a quote from the other answer:

If the Synaptics settings does not appear under Mouse properties after completing the preceding steps, try the following:

  1. Open device manager
  2. Find the touchpad device (“PS/2 Compatible Mouse”)
  3. Right click on the device and click “Update Driver Software”
  4. Select “Browse my computer for driver software”
  5. Select “Let me pick from a list of device drivers on my computer”
  6. ncheck the option “Show compatible hardware”
  7. nder “Manufacturer”, scroll down to “Synaptics”
  8. Under “Model”, the 17.0.19 driver should appear.
  9. Select the driver and click next.
  10. Click “Yes” to the “Update Driver Warning” pop-up.
  11. Restart

Cause of error

It's worth noting that it seems like it failed due to not being properly signed. When attempting to install just the driver, manually, from the device management console, it would allow you to select it, but would fail due to not being digitally signed. It's an odd peculiarity that I hope gets fixed relatively soon.


Previous workaround

The following steps are not recommended, as they use older versions of Synaptic and needs to be downloaded from less-desired locations.

Another fellow troubleshooter already had the issue, and found an older version of the suite, v17.0.6.13, which used to be available, but the host is down.

Simply installing this version, after making sure I had uninstalled previous versions, can "solve" the problem.

Note: Here are two alternative version. Be careful with the download links on the sites, as some ads might give you unwanted software: Link 1: recommended | Link 2: careful!

  • 2
    The installation completed, but synaptics is no wwhere to be found. I went to Mouse, nothing there, I went to Add Remove, nothing there. I need to do a complete manual removal of Synaptics. Think you could help me out? – KickAss Dec 21 '13 at 19:42
  • @KickAss That's a trickier one; I only had to install it once after it had been previously removed, and then simply install it, followed by a reboot. Additionally, you could try to uninstall the driver for your touchpad from device management, where it might show up as "Microsoft PS/2 Mouse". – Thor Dec 21 '13 at 19:54
  • 1
    The second set of links worked for me. – John Kurlak Jan 6 '14 at 6:58
  • 1
    I'd like to highlight that the v17.0.6.13 drivers seem to be explicitly for Acer, and did not work on my Samsung. – Scott Rippey Feb 3 '14 at 7:02
  • @ScottRippey Interesting, I don't think that could be the case, because I myself used it for my laptop from ASUS - are there some references to Acer in the driver package? In which case, I/you should update my answer. – Thor Feb 3 '14 at 7:15

Here is a trick on how to install Synaptics Touchpad Driver v17.0.19

> WIN + I
> Change PC Settings
> Update and Recovery
> Recovery
> Under 'Advanced startup' click 'Restart Now'. Make sure to save your work first.
> Select 'Troubleshoot'
> Advanced Options
> Startup Settings and click Restart
> When it boots up, press 7 to Disable driver signature enforcement
> Install Synaptics as you would normally do.
> Restart

If the Synaptics settings does not appear under Mouse properties after completing the preceding steps, try the following

> Open device manager
> Find the touchpad device (“PS/2 Compatible Mouse”)
> Right click on the device and click “Update Driver Software”
> Select “Browse my computer for driver software”
> Select “Let me pick from a list of device drivers on my computer”
> Uncheck the option “Show compatible hardware”
> Under “Manufacturer”, scroll down to “Synaptics”
> Under “Model”, the 17.0.19 driver should appear.
> Select the driver and click next.
> Click “Yes” to the “Update Driver Warning” pop-up.
> Restart
  • Interesting, I shall give that a go. Thank you – KickAss Dec 29 '13 at 11:56
  • This worked for me for v17.0.19, and I've used it on past versions as well. However, I'd like to add that I had a VERY difficult time getting it to work. I ended up having to use Device Manager to both uninstall the existing mouse driver and also to install the v17.0.19 driver. The Setup.exe in the download just NEVER worked for me. – Scott Rippey Feb 3 '14 at 7:07
  • I'd note that disabling driver signature enforcement is, technically speaking, a security risk. (Whereas the severity is a different case.) – Thor Feb 3 '14 at 7:16
  • Yeah, I definitely don't like jumping through the hoops-on-fire, but I REALLY like having Chiral scrolling, so I jumped. – Scott Rippey Feb 3 '14 at 8:43

I realize this question has already been answered, but I am posting this for future readers.

I tried the solution given by Thor, which was to install an older version. The install succeeded, but I still had no touchpad driver upon system reboot.

I performed the following steps to get around this:

  • Install Synaptics version 17.0.6.13. DO NOT REBOOT.
  • Open the Synaptics install target folder (C:/Program Files/Synaptics/SynTP).
  • Open file properties for oemsetup.bat.
  • At the bottom of the General tab, click Unblock.
  • Reboot.

If you reboot and still have no touchpad driver, you may want to go through each of the files in the install target folder and unblock it.

  • Yeah that sounds about right, like mentioned in the posts above, the problem is with the version 17.0.6.13, every single file in the installation needs to be "Unblock" because Synaptics have messed up the digital signature for that version and so the files are getting blocked by Windows. But thank you for contributing :) – KickAss Jan 28 '14 at 15:38

A very strange way but worked 100%

  1. Just download the driver from synaptics.com

  2. Do not extract the .zip file, launch the setup from the .zip file and setup will continue successfully after answering a dialog box question about installing drivers from Synaptic corporation.

I have tried a lot of versions specially Dell Synaptics touchpad drivers but many errors happened with them.

http://i60.tinypic.com/6iwv8p.png

  • The real problem is the drivers are not properly signed. You have to get around that problem. You do that by unblocking each file that is blocked – Ramhound Mar 15 '14 at 23:21

protected by Community Jul 3 '14 at 0:54

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.