None of the USB ports work anymore on my HP EliteBook 2540p laptop which is running Windows 7 Pro SP1. By "not working," I mean if I try plugging in a thumbdrive or external HDD it does nothing whereas they work perfectly on other machines. I've tried just about everything and no luck. It gets stuck and doesn't complete the process if I try from the device-manager to uninstall, update, or scan for changes concerning the drivers. I've also tried to use the MicrosoftFixIt tool which just hangs there and does nothing as well. I've left things running overnight with each of these attempts and it just hangs there endlessly. The properties for each port claim the device is working properly. Please, help me figure out how to get my USB ports working again!

Edit #1 - I have tried booting off my Fedora LiveCD and the USB ports work fine which indicates that it doesn't seem to be a hardware issue. I need to get the ports working again in Windows though.

Edit #2 - I tried using the Microsoft USB View tool, but don't know how to interpret the output. Anyhow, when I plug in my thumbdrive a yellow circle with an exclamation mark comes up for that USB port and it says "DeviceConnected." Here is the full output in case anyone can make sense of it and determine what problem(s) may exist:

Device Descriptor:
bcdUSB:             0x0200
bDeviceClass:         0x00
bDeviceSubClass:      0x00
bDeviceProtocol:      0x00
bMaxPacketSize0:      0x40 (64)
idVendor:           0x8564
idProduct:          0x1000
bcdDevice:          0x0100
iManufacturer:        0x01
0x0409: "JetFlash"
iProduct:             0x02
0x0409: "Mass Storage Device"
iSerialNumber:        0x03
0x0409: "VYWCFQTO"
bNumConfigurations:   0x01

ConnectionStatus: DeviceConnected
Current Config Value: 0x00
Device Bus Speed:     High
Device Address:       0x05
Open Pipes:              0

Configuration Descriptor:
wTotalLength:       0x0020
bNumInterfaces:       0x01
bConfigurationValue:  0x01
iConfiguration:       0x00
bmAttributes:         0x80 (Bus Powered )
MaxPower:             0x32 (100 Ma)

Interface Descriptor:
bInterfaceNumber:     0x00
bAlternateSetting:    0x00
bNumEndpoints:        0x02
bInterfaceClass:      0x08
bInterfaceSubClass:   0x06
bInterfaceProtocol:   0x50
iInterface:           0x00

Endpoint Descriptor:
bEndpointAddress:     0x01  OUT
Transfer Type:        Bulk
wMaxPacketSize:     0x0200 (512)
bInterval:            0x00

Endpoint Descriptor:
bEndpointAddress:     0x82  IN
Transfer Type:        Bulk
wMaxPacketSize:     0x0200 (512)
bInterval:            0x00

Edit #3 - I used the ServiWin tool and discovered that the USBSTOR service is stopped and I am unable to manually start it. It states the error message: "Error 1058: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it."

Here are my registry settings for it:

USBSTOR registry settings screenshot

Edit #4 - I used the USB Oblivion tool which erases all traces of USB devices from the Windows registry. I figured it might help flush out any corrupted data that might be causing problems.

  • Check to see if your system is allowed to install drivers perhaps: support.microsoft.com/kb/2500967 – Jeff F. Dec 23 '13 at 17:11
  • @Jeff F. - It is set to automatically install drivers. – THE DOCTOR Dec 23 '13 at 18:09
  • I mean if I try plugging in a thumbdrive or external HDD it does nothing Define “nothing”. Does it make the bing-bong sound? Have you tried other USB devices like keyboards, mice, USB lamps, etc.? Do the LEDs on the flash-drives or other devices turn on when you plug them in? – Synetech Dec 23 '13 at 19:08
  • If I plug in a thumbdrive for example - it lights up, makes no sound whatsoever, and the drive doesn't show in Windows Explorer nor is it accessible from the command prompt. Same happens with other thumbdrives and my external hdd. I tried plugging in the receiver for my wireless mouse and it didn't work at all. – THE DOCTOR Dec 23 '13 at 19:37
  • I tried plugging in the receiver for my wireless mouse and it didn't work at all. Then you can ignore the premature answers that mention fiddling with USBSTOR since that is obviously not the problem. It seems like Windows is somehow ignoring your USB ports. You used a device-manager tag, yet said nothing about what you see in it. Are there any warnings or errors? – Synetech Dec 23 '13 at 19:46
up vote 3 down vote accepted
+50

On several of our older Dell desktop machines, we have had this same problem. My solution was to go into Device Manager and delete all the USB controllers and hubs. Reboot to allow Windows to re-discover the hardware and reload the drivers. This problem occurs maybe twice a year and this procedure fixes it each time.

  • I've tried this, but unfortunately it doesn't allow me to delete any of them and instead the progress window just hung there for over a day when I tried to. – THE DOCTOR Dec 23 '13 at 20:47
  • @THEDOCTOR, had you rebooted though? It sounds like you had missed that step which was critical. If un-intalling the USB devices from the Device Manager and letting Windows re-install and re-initialize them was the key, then this guy should get the credit (and bounty). 76732 was the first one to say it; their answer was 20 minutes even before my comment. (harrymc just copied what others said about the Device Manager into his own answer after you had confirmed it helped; his actual response was just an unrelated guess.) – Synetech Dec 23 '13 at 22:31
  • @Synetech - I did reboot before once or twice before today and it was still getting stuck when I tried to uninstall the drivers. Right you are about credit for the answer. My bad. Thanks for tracking that down. – THE DOCTOR Dec 23 '13 at 23:05
  • Out of curiosity, what was the dialog that kept hanging? Was it this one? It’s good when a problem gets fixed, but if it happened “on its own”, then it leaves you vulnerable to it happening again. If you can identify the dialog that was hanging, then maybe the reason can still be explained and the information prove useful for the next time you run into it. ;-) – Synetech Dec 23 '13 at 23:08
  • @Synetech: I had copied nothing - I had not read the other answers. Please don't insult. – harrymc Dec 24 '13 at 9:54

Look in c:\windows\inf (ensure you can see hidden and system files) and see if you can find the two files named usbstor.inf and usbstor.pnf.

If they are missing, you need to restore/replace them.

Copies of these files may be found in C:\Windows\System32\DriverStore\FileRepository inside a folder named usbstor.inf_xxxxxxxx. If more than one such folder exists, use the folder with the latest (newest) date.

Create a System Restore point first and reboot afterwards. If the above doesn't work and the problem is recent enough, you could rollback Windows to a time that the USB ports did work.

You could also verify using regedit that the key HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\USBSTOR has an entry named Start whose value is 3.

See also if there is anything useful in the Event Viewer.

You could also try the oldest remedy of them all : Uninstall all the USB hubs from the Device Manager and then reboot.

  • 1
    Both of those files exist in the folder you mentioned and were last modified in 2011, so it doesn't look like they were corrupted or anything. As shown in the above screenshot of my registry, the Start value is already set to 3. – THE DOCTOR Dec 23 '13 at 19:32
  • Not to mention the USB mouse doesn’t work, so it is obviously NOT the USBSTOR service that’s the problem. – Synetech Dec 23 '13 at 19:44
  • Anything useful in the Event Viewer? Have you tried to uninstall all the USB hubs in device manager then reboot? – harrymc Dec 23 '13 at 20:03
  • @harrymc - The event viewer doesn't tell me anything new. It just says that "The USB Mass Storage Driver service failed to start due to the following error: The service cannot be started, either because it is disabled or because it has no enabled devices associated with it." I have tried uninstalling the USB hubs from the device-manager as mentioned in the 1st paragraph of my question and it just hangs there with a progress bar for 24+ hours. After that, I figured it wasn't doing any good and I killed it from the task manager. – THE DOCTOR Dec 23 '13 at 20:44
  • @THEDOCTOR, it’s not starting the service because as it says, it has no associated devices to load it for, and that’s because your USB ports are off. – Synetech Dec 23 '13 at 20:52

Assuming the BIOS does not provide a way to disable USB, and you have checked to ensure they've not been disabled in the BIOS...

Boot to a 3rd-party OS (a current Linux LiveCD of some kind should do it) -- Do the USB ports work? If not, then you have a hardware issue and you need to get your notebook repaired.

Also, the BIOS should detect, and will most likely show you (bootable) USB drives in the boot-order menu. If they don't show up there then, again, it signifies dead USB ports -- a hardware issue -- time to take it in for repair.

If these ways can detect the USB drives, and they work, then your Windows is messed up and it's probably best/easiest to back it up and try a fresh install.

  • I've determined it's not a hardware issue. A fresh install isn't a very good option for me given that this is a work laptop with a lot set up on it which would be a royal pain to reinstall/reconfigure. Isn't there some other way I can attempt to fix my USB ports without having to reinstall Windows? – THE DOCTOR Dec 23 '13 at 16:41
  • How did you determine is not a hardware problem? Did you check/try any of the things I've suggested here? – Ƭᴇcʜιᴇ007 Dec 23 '13 at 16:50
  • Yes, the ports work just fine when I boot off my Fedora LiveCD. – THE DOCTOR Dec 23 '13 at 16:55
  • You should edit your original question to include that information, as well as anything else you've already tried, and what the results were. – Ƭᴇcʜιᴇ007 Dec 23 '13 at 16:56

We've had this issue for some time in our enterprise.

The best method thus far has been to...

C:\windows\system32\drivers (you may need to show hidden files) take ownership of all USB.sys files.

Rename them to .old in Device manager, uninstall the failing USB devices and delete driver software if presented with that option.

While still in Device Manager, go to "Action" and then click on "Scan for hardware changes". After the system installs clean drivers, you may have to manually install the USB 3.0 Extensible Host Controller on Dell laptops.

If it throws an error about incompatibility, you will have to extract the contents to a folder on the hard disk drive and point Device Manager to it.

  • This duplicates the accepted answer and adds no new content. Please don't post an answer unless you actually have something new to contribute. – DavidPostill May 24 '16 at 23:06

I just battled a similar problem, and I like to take a note on this topic.

In my case, the two Safenet USB authentication keys stops working after a reboot, and further checks show that all USB ports have stopped working. In devmgmt.msc, both PCI USB Host Controllers have alert signs on them, and the Intel® USB 3.0 Extensible Host Controller also have warning signs. Keyboards, USB drives, etc... Nothing works.

What didn't work

Apparently this has nothing to do with a specific USB device driver. I tried uninstall, reinstall, update the USB host controllers drivers, and rebooted various times. I also updated the EMI driver out of despair. Nothing worked.

What worked:

Try to sort things out, starting from inspecting the drivers loaded.

Clicking on the Driver Details button on Host Controller's Driver tab, a list of all the driver files related to the current driver is displayed.

From there I noticed all the other files have been signed, and only one entry, USBPcap.sys, is not a signed driver. Someone installed a Wireshark USB sniffing driver onto the development server. After removing this driver in appwiz.cpl, a quick reboot solved everything.

What is not solved

I still don't know how Wireshark's driver survived all those uninstall reinstall cycles, and got loaded as usual. These software drivers don't have an device entry in devmgmt.msc, and it's very easy to neglect their existence.

If you have a malfunctioning USB Host Controller that doesn't work after driver update, etc., unlike me who went on a wild goose chase, one really should check the actually loaded drivers first.

Have you found a solution yet? If not let's get down to basics...You need to run the System File Scan (SFC /SCANNOW) in case you have Windows 7 System file damage. If that doesn't fix the problem, and you'd lose too much with System Restore (which is usually the situation) to an earlier date/time, you really do need to reinstall Windows. But wait!

You don't need to do a fresh install.

It's a lengthy process (not as long as a fresh install) but, do what many call a 'REPAIR' install. This option will keep your programs & data without loss. Have your motherboard driver disk handy, or know where to locate the drivers in your download folder; you may need them. I've used it many times for this type of problem, which is usually system file or Registry damage with no apparent solution. It can be a tedious process, with several Microsoft gotchu's, so you need to Google 'Windows 7 repair installation' for detailed instructions, before you start and print it for reference during the process. The variations are almost endless and Microsoft doesn't make it easy! I checked this site for links for this process, but I couldn't find one!

Microsoft confuses most and call this option an 'UPDATE'. It's both in fact. It refreshes the Registry & scans ALL the hardware during the repair/update. The repair will ask for your Windows 'Key' and when done, 'Authentication' again.

Be sure to do a mirror of your system disk, and make a repair disk if you don't have one already, before you start, for recovery in case of problems. Making the Windows 7 mirror/backup is easy and fast.

You will need a second HDD already installed, for the mirror, since you can't connect a USB. Or use any offline backup software with an image capability. Don't bother trying to use DVDs for the mirror. You need way too many.

Also be sure to run a full anti virus (AV) scan using Windows Defender Offline, (it's actually MSE) AND the FREE OFFLINE Malwarebytes or Kaspersky's free full OFFLINE scan (with the Network connected for the latest updates) in case you've picked up a root kit which the online versions of most AVs won't find with Windows running.

Run TWO versions of an AV scan since very few will find all infections in one pass on their own! You can find all the software I've referenced, using Google or your preferred search engine. If a virus has infected the system, and you don't run an AV scan, the Windows 7 Repair will also be infected. It's also a good move to run a full chkdsk (all five passes), on the disk(s), to make sure there's no logic problems or sector damage after the AV scan & before the Windows 7 repair.

The Repair option will of course necessitate an SP re-installation and all Windows 7 patch updates again. During each of the above steps, before the Repair is started, check to see if the USB devices are working again. It's a long shot, but you never know!

You will need a fair bit of spare system HDD empty space. The repair creates a backup in a C:\windows.old folder to recover things that might have gone missing after the repair. If everything looks OK, you can delete this folder.

  • Thanks for your answer. The problem has been resolved by user76732's suggestion to uninstall the USB drivers and reboot. – THE DOCTOR Dec 26 '13 at 16:49

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.