0

If I visit http://www.endsleigh.co.uk/Pages/Endsleigh-App.aspx then the request completes with a URL of https://www.endsleigh.co.uk/personal/

When this kind of thing has happened before with other sites, I've seen 3xx responses in Firebug, followed by the request to the second URL. But this time I don't see that, and Firefox's Live HTTP headers add-on doesn't show this either. It's as if I'd never typed in the first URL.

Then I tried it in Chrome, and saw a 301 redirect. Why would this be shown in Chrome but not in Firefox's native tools or headers add-on or indeed in Firebug?

  • I just tried it on chrome and firefox, but on both browsers, I get redirected immediately without seeing any 301 redirect. Maybe it is the speed of the connection, you see it on Firefox when the network is slower? – vinnief Dec 19 '13 at 21:39
  • 1
    It could be because the 301 redirect is cached by Firefox. You could try clearing the Cache via History (Alt + S) > Clear Recent History with an appropriate Time range to clear. Alternatively, Forget About This Site via the History library. Clearing cache/history – vWil Dec 20 '13 at 0:03
0

It's hard to explain why firebug would not show the header. I would clear the cache, make sure accessibility.blockautorefresh=true, and lastly use the NoRedirect addon. You can then add two custom rules, leaving unchecked all three checkboxes

http://*.*
https://*.*

or perhaps even one regex rule as in this image:

enter image description here

I would hope after these 3 changes, that firebug would finally record the sent header.

| improve this answer | |
  • Clearing the cache did it – KnewB Apr 4 '14 at 13:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.