3

This problem has surfaced recently. After I switch on my laptop from hibernate/sleep mode, it can't connect to the Internet. It displays all the available networks (wireless) but it never succeeds in connecting to the Internet. It is able to connect to the router though.

I tried many other solutions like disabling windows to turn off the adaptor, but none of these are working.

Additional info:

This problem persists on both wired and wireless. Rebooting will solve the problem until next sleep/hibernate. I am not sure about BIOS, but I had updated windows and drivers recently. Mine is a Dell Latitude E6410 laptop

5
  • We need details to be able to help you. Does a wired connection work? Does it reconnect after rebooting? Do you have the latest BIOS update, Windows updates and drivers? What brand and model of laptop?
    – CharlieRB
    Dec 20, 2013 at 12:43
  • Have you tried System Restore back to a date before it stopped working?
    – CharlieRB
    Dec 23, 2013 at 13:31
  • It is able to connect to the router though. So it's not a problem with the adapter itself. (You can ping your router? Make sure...) Are you getting "limited connectivity"? Could you post your ipconfig /all and route print info after you can't connect? It could be you lost (or didn't get) your DNS-server info after sleep.
    – Rik
    Dec 23, 2013 at 14:41
  • it's worth pointing out that under control panel - network connectinos, you can right click your LAN icon and click diagnose, whenever there is a problem. that is quicker than restarting and you might find it's a temporary fix of sorts. You can also right click your network card under device paneger, look for a power management tab that talks about turning off the device to save power. "allow the computer to turn off this device to save power" and untick it since you have an issue
    – barlop
    Apr 26, 2014 at 21:57
  • related: superuser.com/q/652276/376608
    – glS
    Feb 4, 2015 at 10:01

3 Answers 3

1

Something to try- You can right click your network card under device manager, look for a power management tab that talks about turning off the device to save power. "allow the computer to turn off this device to save power" and untick it since you have an issue

also it's worth pointing out that under control panel - network connectinos, you can right click your LAN icon and click diagnose, whenever there is a problem. that can "fix" it quicker than restarting (I tend to set it to DHCP(the default) when doing that).

0

After waking from hibernation or sleep the router will still be available though the connection would not be able to connect but will show connected (though you wouldn't be able to use internet using any browser or download manager). What you need to do is to disconnect and then reconnect again, it will reconnect( could take some time maybe 1 min more than usual ). After this you would be able to use internet again without any problems concerning the hibernation. You need to do this after every hibernation although if your computer is on sleep mode and you wake it after some time (less than 30 mins after sleeping) then you needn't do it again.

5
  • I tried what you suggested, but still it does not work. It says "connected to network" but I am not even able to ping the router. It says "Identifying network" and then pop ups a message "There was problem connecting to network"
    – Rakesh
    Dec 26, 2013 at 3:29
  • Did you try to turn off your router and then switch it again or can also try to remove the cable once and then re-plug it again. Does it disconnect properly as sometimes it shows disconnected and doesn't get disconnected properly.
    – Hunter
    Dec 26, 2013 at 10:21
  • I don't have to turn off the router, as the problem is not in the router because other devices are able to connect to router. Problem is in my windows laptop - after sleep or hibernate. I hope you get my drift.
    – Rakesh
    Dec 26, 2013 at 10:26
  • I get it but I suggest that because it's sometime that windows cannot reconfigure your router back to it's original configs so I told you to turn off the router. I know it's not the problem of your router. If you don't like to turn off you can try to remove the cable and then plug it again.
    – Hunter
    Dec 26, 2013 at 10:29
  • You write "What you need to do is to disconnect and then reconnect again," <-- Why don't you explain what you mean by that. There are different ways of doing that, why not list the ways, or specify the way you mean, if you mean one particular way
    – barlop
    Sep 8, 2015 at 17:49
0

What works for me with my wired connection: Unplug router, then put windows 7 (32) machine to sleep. When you're ready to go back to work, simply reverse those steps: wake up machine, then replug router. It may take 30 seconds or so once the router shows that it is alive.

1
  • try my method, it may be quicker for you
    – barlop
    Sep 8, 2015 at 17:50

Not the answer you're looking for? Browse other questions tagged or ask your own question.