4

I've got i7 processor, 8 GB of RAM, integrated Intel HD Graphics 3000 and GeForce 540M in my notebook. For some reason in "Edit > Performance > Graphics Processor Settings" Photoshop CS6 sees only Intel HD Graphics 3000 card and it works so slow that I can't do anything. When I disable that and check it to use CPU only, it works even slower.

I've searched Google for similar issues but nobody seems to have it. Does anyone know if I can switch to GeForce somehow? I don't see such option in the settings.

5
  • 1
    What is your monitor hooked up to? Are you using Virtu or anything like that? – David Schwartz Dec 20 '13 at 13:56
  • Are you on a laptop or desktop? Have you tried updating your drivers? Have you tried disabling the integrated graphics completely? – DanteTheEgregore Dec 20 '13 at 14:18
  • Doesn't Windows just use one graphics card? Have you checked what graphics card windows is using? I don't know much about graphics card models but are you saying you've got two graphics cards integrated int your notebook? an Intel..3000 and a GeForce.. ? Photoshop aside, what is windows seeing? surely photoshop just sees the one windows sees? or can photoshop use a different one to what windows sees?!?! – barlop Dec 20 '13 at 15:12
  • @DavidSchwartz I have Dell XPS 15 and Windows 7 uses Intel HD Graphics 3000 most of the time. I don't have any other software or hardware. Just fresh Windows with default drivers (last updated today). I noticed that 540M gets activated when I'm launching some game or occasionally but not always a HD movie. It always switches to GeForce when I plugin in HDMI monitor too. Other than that it uses integrated card. – Plon Dec 20 '13 at 15:56
  • @barlop See David Schwartz's comment. Windows can utilize multiple graphics cards in different scenarios. – DanteTheEgregore Dec 20 '13 at 16:23
7

You should probably use the Nvidia Control Panel and set high performance on Adobe Photoshop. I own AMD unfortunately but i remember there was the setting panel in "Manage 3D Settings". From there you should be able to select an application from the drop down menu, in this case Photoshop and set it to "High Performance". After you try this solution check back in photoshop and see if the app is using the right vga.

Here's a screenshot of the specific Nvidia setting you should check:

enter image description here

2

I had some similar issue but with the Photoshop crashing all the time with the dual adapters bug and I found a solution that might help you:

  1. Before opening Photoshop go to My Computer > Manage > Device Manager and disable the Display Adapter that you don't want to use
  2. Open Photoshop and check in Preferences > Performance if the wanted display is selected.
  3. If the Adapter is correctly selected re-enable the disabled one from the Device Manager

this is annoying but does the trick.

1

Windows 8 has a new feature that allows you to right click on a program icon and choose the default graphics processor. These new i7 chips work better with Windows 8. An option for you is to ditch Windows from seeing the Intel processor's graphics altogether and use only the advanced graphics processor. You will need to load your system BIOS and disable the HD 3000. I know you can do this on most Dell's. You may need to upgrade your BIOS if you do not see the option.

0

If you're on Windows 10 and none of the above solutions worked, check this out:

  1. Go to Windows Settings -> System -> Display -> Graphics Settings
  2. Choose "Classic app"
  3. Click Browse, add your app
  4. Click Options and select "High Performance"

enter image description here

Photoshop should now recognize your other card and start using it. This was the only solution that worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.