13

The Problem

I CANNOT switch Google accounts without starting a new browser or going incognito! Whenever I click sign out, it pops up with this window and there is no way, I can tell, to enter in a new user name.

Steps to Reproduce

  1. Sign into Gmail.com with "Stay signed in" checked.
  2. Click the Sign Out link in Gmail.com.

Every single article I have found online talks about a "Switch to another account" link, but it is clearly missing from my login window.

Please help me. It is critical that I can switch between my various corporate accounts! They're with distinct organizations with contractual obligations prohibiting me from "adding" them to an account, not that I would want to, anyway.

google login screenshot

12

This is what works for me:

When I want to login into one of my GMail accounts, I visit this URL:

https://accounts.google.com/Logout?continue=https%3A%2F%2Faccounts.google.com%2FServiceLogin%3Fsacu%3D1%26il%3Dtrue%26continue%3Dhttps%253A%252F%252Fmail.google.com

This will log me out of whatever Google account I was logged in previously (if any), and give me 2 empty login fields (username & password). After logging in, I'm redirected straight to GMail.

To get this workflow semi-automated in my password manager (I use KeePassX), I created a shortened URL:

http://tinyurl.com/mokz32r

because the program didn't play nicely with the URL encoding.

1
  • 1
    Thanks. This helped me when I had alternative account options at login where each account choice resulted in the same account login being presented.
    – Non person
    Mar 12 '17 at 13:48
1

Click the "Manage accounts on this device" and you should have option to "Choose", "add" or "Remove" accounts. Add the accounts and log on, sign off, add next account.

The next time you go to the "sign in" option, you should see your several accounts that you added for easy access.

I have three account and this is the way I set mine up.

1
  • I do NOT wish Google to know explicitly that three separate corporate accounts are linked together, much less to my own personal gmail.
    – hopeseekr
    Dec 23 '13 at 13:51
-1

To solve this one should switch on the compatibility mode of Internet Explorer. This should solve your problem if you're using Internet Explorer. Otherwise you can use google chrome and should work fine.

1
  • Hmm. OP doesn't mention a specific browser.
    – DavidPostill
    Feb 2 '16 at 18:39
-2

Simply Clear Data USING CRTL+SHIFT+DELETE and select the begining of time.... check all the boxes except the passwords so you don't lose the passwords and it's done!

Not the answer you're looking for? Browse other questions tagged or ask your own question.