12

We have Windows 2008 r2 servers running at the moment.

If I log into the server using remote desktop connection, and then someone else tries to log into the same server while I am working on it, I get thrown off the server and am displayed the following message:

Your Remote Desktop session has ended.

Another user connected to the remote computer, so your connection was lost. Try connecting again, or contact your network administrator or technical support group.

My question is, is it possible to configure the server to stop this from happening. So instead of kicking off the user who is already working on the server, stop the second user from connecting or allow both to connect at the same time?

  • You can be evil and remove others from authorized remote users :P....I know its not gonna work for you and that's the reason this is going as comment instead of answer – tumchaaditya Jan 3 '14 at 17:08
10
+50

The situation you described would only happen if the two users are using the same username or you have hit the maximum concurrent users for the server (however you said there are only 2 people involved and the error you had would not happen till a 3rd person logged on and you don't have terminal services licensing set up).

If you are having the "same username" problem the two ways to fix it are to have the users use separate usernames to log in or to allow a single user to have multiple sessions open.

If you are having the "maximum concurrent users" problem you need to purchase a terminal services license and enable it on the server.

  • This is more complete answer – tumchaaditya Jan 3 '14 at 17:08
7

Go to Start > All Programs > Administrative Tools > Remote Desktop Services > Remote Desktop Session Host configuration. Double-click the setting "Restrict each user to a single session" and change it to no. Voila!

1

If the Terminal Server role service is installed, you can use mstsc /admin to start an administrative session that non-administrators cannot preempt. This switch has no effect if the Terminal Server role service is not installed.

For more information see :

Changes to remote administration in Windows Server 2008 section "How the /admin switch behaves"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.