1

I am using CentOS 6.5. I installed MySQL Server 5.5 from a .rpm package (downloaded from the official MySQL site) using the default .rpm installer. I also installed MySQL Client package the same way.

As far as I know, mysql process is MySQL client, and mysqld is MySQL server - although I'm not sure.

The problem is that the mysqld process is not running. When I type service mysqld start or service mysqld status I get the same error message

mysqld: unrecognized service

However, mysql process is running fine. I was able to run queries successfully using the mysql command.

I need to be repository-independent, so I am not supposed to use yum.

When I run /usr/sbin/mysqld start, I get the following error:

[ERROR] Fatal error: Please read "Security" section of the manual to find out how to run mysqld as root!
[ERROR] Aborting
[Note] mysqld: Shutdown complete

2

Name of the MySQL service in official rpms provided by MySQL is mysql.

So you need to use service mysql start to start the MySQL server. The command starts MySQL daemon mysqld.

The client program has the same name mysql.

In the packages provided by CentOS the service is named mysqld.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.