3

at my office at work I have internet provided by the building. Within my office I have a D-Link DIR-632A with Firmware: DD-WRT v24-sp2 (03/25/13) std. I have 2 PCs hardwired, 4 PCs connected through wireless, 2 phones through wireless, 1 VOIP (Vonage) phone hardwired, 2 printers (1 hardwired, other wireless). Very often I get internet loss. I was able to replicate the issue one time, while downloading a very big Mac Update the other machines couldn't even bring up Google.com. As soon as the update was stopped, the internet on the other computers started working. While the update was going, DD-WRT admin webpage was reporting around 12 Mb of bandwidth usage through the WAN, which I believe is what the building caps me at.

According to the Network Admin of the building the problem seems to be my router, which "he doesn't trust because of the firmware". Furthermore, he says that since I don't have it configured to distribute and give priority that is the expected behavior: the Mac is eating the total bandwidth and the other computers can't get anything.

It is my understanding that is the job of the router to be able to distribute the bandwidth as necessary. It should automatically lower the amount of bandwidth allocated to the Mac when new requests come in from other computers/processes and that it should work like that by default. Am I correct? Or should I configure my router like the Admin suggests? I have never run into this issue before. As a matter of fact when I'm watching movies at home, using the same firmware, and other processes start using the internet the quality lowers due to less bandwidth available to that machine.

What am I to do?

2
+50

Almost all downloads are done over TCP, and TCP tries to go as fast as possible without making congestion worse. So your download of a large Mac OS X update will be over TCP, and it will try to use all of your available bandwidth. And that's really what you want TCP to do; you don't want your downloads to go slow for no good reason. TCP watches for dropped packets as a sign of congestion and temporarily backs off its speed a little when it sees that, then speeds back up over a short period of time until it sees another lost packet. In this way it kind of "gently bumps its head against the ceiling" of available bandwidth, without making matters worse. There are actually more sophisticated congestion-avoidance algorithms that modern TCP stacks employ, but they are beyond the scope of this answer.

However, even if your routers and hosts aren't doing QoS, other devices on your network should still get bandwidth, because no one gets priority on putting packets onto the wire. So all else being equal, if you started another big download while the first one was still going, they should automatically share the bandwidth roughly 50-50 and both download at 6mbps.

QoS is only strictly necessary when you have the capability of maxing out your bandwidth, and you need to guarantee a certain amount of bandwidth (or a certain low latency level) to one or more traffic flows (such as VoIP calls).

So your problem of not being able to even load a web page just because a big download is going on is a bug, even for a non-QoS network. Setting up QoS may work around the problem, but it won't solve the root cause.

I would suspect that the root cause has to do with the building's traffic-shaping router enforcing your bandwidth cap in suboptimal ways, but it would be pretty hard to prove that without someone well-versed in TCP looking at simultaneous packet traces from both sides of the traffic-shaping building router, at a time when the problem was happening.

3
  • Is there anything I can do to test whether the problem is with the building? Maybe get another router? Configuration? Anything? – Jonas Stawski Jan 8 '14 at 20:16
  • Have to agree with this. There should not be a need to set up QOS. FWIW I have DDWRT as my home router and do not have the problem that @Jonas is having. – chue x Jan 9 '14 at 0:49
  • Is it possible to temporarily substitute a "dumb" switch for the router? If so, that will eliminate many variables, and if the problem persists than your building network is just not gracefully handling the possibility of and overloaded port. – BowlesCR Jan 13 '14 at 18:41
3

DD-WRT supports Quality of service (QoS), which one can use to ensure that one application doesn't hog the entire bandwidth, and does it pretty well.

See these articles for instruction on how to use QoS :

Ensure a Fast Internet Connection When You Need It
How to Prioritize Your Network Traffic with DD-WRT
How to Supercharge Your Router with DD-WRT
DD-WRT wiki - Quality of Service

2
  • Isn't the router's job to automatically (without any configuration) distribute the load if more requests come in? In other words if computer A is eating 12mbs of bandwidth and computer B wants to use 100kbs, shouldn't the router take 100kbs from A and give it to B? – Jonas Stawski Jan 8 '14 at 16:53
  • 1
    That's the job of that part of the router called QoS, which is unfortunately not enabled by default. In your case, it's also possible that you might have a QoS problem between the wired and wireless networks, where one might have priority over the other without the right setting. QoS settings may need to be examined and some experimentation may be unavoidable. – harrymc Jan 8 '14 at 20:05
1

In addition to harrymc's answer about using QoS, you should also download InSSIDer and check to make sure there's no nearby wireless interference. This could also be severely affecting the performance of the wireless clients of the router.

1
  • The problem occurs with wired connections as well, so I don't think it's related to the Wireless. – Jonas Stawski Jan 8 '14 at 16:54
1

You need to diagnose two independent problems;

1) Your wireless: transfer files between two computers on your wireless network. What does it max out at? Try at different times during the day. Does it adversely affect other computers in your office. If yes, try minimizing 2.4 ghz congestion.

2) Your internet connection; Grab an ethernet cable for this and then download something big. I'd suggest http://mirrors.kernel.org/centos/6.5/isos/x86_64/CentOS-6.5-x86_64-bin-DVD1.iso.

If you find that your bandwidth is unusable on the other computers in your office when you are downloading as in 2), you are likely seeing a problem that is not related to your wireless AP.

You can suggest doing things like checking the buffer size on the upstream router. Too large a buffer or QoS queue can cause problems similar to what you described.

Re: Why buffers matter;

TCP only responds to network congestion. If you have very high network queuing (i.e. a large buffer on the sending router and/or receiving router) it will cause the congestion avoidance algorithms which are apart of TCP to break down.

See an explanation of buffer bloat on http://lwn.net/Articles/470641/.

-1

I think your problem is the same as I was having. Its a DHCP issue, your router issues DHCP to the clients and when it goes to renew the lease it has issues. Once I put a static IP on my machine, all the intermittent internet losses went away. I had to same issue and was getting very frustrated, however, I use mine as a wireless switch. So if its happening to the wireless, I cant help you there. Give the LAN PCs a static IP and see if that resolves your issue. I believe this is a known issue within DD-WRT.

2
  • No. DHCP issues would not explain the correlation to the large download. – BowlesCR Jan 13 '14 at 18:39
  • Unless it really has nothing to do with a large download. – Mike K Jan 13 '14 at 22:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.