I am using Ubuntu 9.04 with xfce and it keeps wanting to automount drives that I plugin, is there a way to disable this?


2 Answers 2


From here

Uninstalling gnome-volume-manager seems really extreme... Simply turning off GVM's automounting of hot-plugged and inserted removable media would be simpler.

From the Gnome Panel, click System->Preferences->Removable Drives and Media and then uncheck the first two boxes on the storage tab. This will turn off automounting for everything not defined in /etc/fstab, and you can turn it back on if desired as easily.

If you just wanted to disable automounting of certain devices you could give them their own line in /etc/fstab, making sure that the fourth field of their line include noauto so they are never automounted.

alt text


Run Nautilus and open Edit => Preferences > Media. Turn off "Browse media when inserted".

  • 1
    Is there a similar tool for Ubuntu 12.04 ?
    – Patryk
    Jul 19, 2012 at 20:44

Run gnome-volume-properties in the terminal. Uncheck whatever you do not want mounted automatically (Storage, CDs, etc).

alt text

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .